All users were logged out of Bugzilla on October 13th, 2018

Searching in history doesn't update match count

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
7 years ago
8 months ago

People

(Reporter: esa.peuha, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
When searching in the Library window, the list of matches is updated after every keypress, but the number of matches isn't. Apparently this is unintentional; http://mxr.mozilla.org/mozilla-central/source/browser/components/places/content/places.js#936 has a call to onContentTreeSelect which by the preceding comment is clearly meant to update the details pane, but onContentTreeSelect calls _fillDetailsPane only when the test on http://mxr.mozilla.org/mozilla-central/source/browser/components/places/content/places.js#633 is true, and it can't be true when entering a search string because the focus is necessarily on the search box. I think line 936 should call _fillDetailsPane directly.
(Reporter)

Comment 1

7 years ago
(In reply to Esa Peuha from comment #0)
> I think line 936 should call _fillDetailsPane directly.

Scratch that, there's nothing wrong with line 936 calling onContentTreeSelect. The problem is that the condition on line 633 is wrong; instead of checking if the treeBoxObject is focused, it should check if none of the items in the tree is selected.
We no longer display the list of matches when searching.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.