Network Solutions webmail doesn't work in Firefox 10

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: MattN, Assigned: ninamacie)

Tracking

Details

(URL)

(silkphoenix from bug 690287 comment #14)
> I upgraded to FF 10 and immediately found one website couldn't recognize the
> two-digit version number. It's the webmail website from
> www.networksolutions.com. It said I do not have a new FF version, it needs
> to be 2 or over.
> 
> Revert back to 9.01 did not help, the warning still came up even I delete
> all cookies. I have to do a System Restore to fix the problem. I am sure
> there are other website have the same problem but don't want to keep FF 10.0
> to check.

(In reply to silkphoenix from bug 690287 comment #17)
> To update my comment (# 14), the url is: 
> http://mail.xxx.com/interfaces/sso/login.php
> 
> "xxx" is the website name of each user, which is different from user to
> user. It's the web mail program hosted by www.networksolutions.com.
> 
> I hope that helps.

Comment 1

7 years ago
To be able to test this ourselves, we're going to need an example URL where this happens. The URL you gave isn't a valid URL.
Assignee: english-us → ninamacie
I found a demo login on their website: http://mail.nsmaildemo.com/interfaces/sso/login.php
It seems to work on Nightly 12.0a1 but detects Firefox 10.0 as outdated and redirects to http://mail.nsmaildemo.com/interfaces/sso/upgradebrowser.html
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

7 years ago
Matthew,  Yes, when I tried to log in my Network Solutions Webmail with FF 10, it redirected to the url you posted above (upgradebrowser.html...). And even after I revert back to 9.0.1, it still redirected me to the same url and I cannot log in. I have to do a System Restore to fix the problem.
(In reply to silkphoenix from comment #3)
> Matthew,  Yes, when I tried to log in my Network Solutions Webmail with FF
> 10, it redirected to the url you posted above (upgradebrowser.html...). And
> even after I revert back to 9.0.1, it still redirected me to the same url
> and I cannot log in. I have to do a System Restore to fix the problem.

Thank your for confirming that the symptoms I found are the same.

Network Solutions seems to be using Open-Xchange as their webmail solution but I don't get a notice on Open-Xchange's own demo website [1] so I suspect this is NS-specific UA-detection.

[1] http://www.open-xchange.com/en/try/online-demo.html
(Assignee)

Comment 5

7 years ago
Since I am a paid client of Network Solutions, I'll contact them to see if they can fix the problem. Once I hear from them, I'll post my update here.

Thank you, Matthew, to create this bug report.
(In reply to silkphoenix from comment #5)
> Since I am a paid client of Network Solutions, I'll contact them to see if
> they can fix the problem. Once I hear from them, I'll post my update here.

Thanks, that's a good next step.

I've also filed a report with them:
"Thank you for submitting your online Network Solutions Service Request.  This is an automatic reply to let you know that our Customer Service Department has received your request and it has been assigned Service Request Number 1-574552885."

Comment 7

7 years ago
A user reported this problem 2 weeks ago, see https://support.mozilla.org/en-US/questions/913000
mha007. I don't think it is the same problem as this user reported a problem w/ Firefox 9 and not Firefox 10.
(In reply to Jean-Yves Perrier [:teoli] from comment #8)
> mha007. I don't think it is the same problem as this user reported a problem
> w/ Firefox 9 and not Firefox 10.

Actually, if you look in the right column of the SUMO message boards, you'll see the user's UA string was for Firefox 10 so they were probably a beta user: 
Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0
Ah, oh. Didn't notice the system info on the right, sorry.

:MattN, I suppose that you didn't got feedback from them?

It is important to note that, by experience, technical problem of these kinds are often ignored (i.e. they send back a pre-written e-mail but don't really act by escalating the problem to the devs team) by post-sales unless they got a lot of reports. 

That means that we should ask every individual, company experiencing the problem to send a request for support. Only if the problem raise in their support statistics will it get a chance to be escalated to the dev team.
Correct, I didn't hear back yet. I agree with what you're saying when it comes to large companies such as NS.

Cww and kev were discussing this problem in #planning on IRC the other day.  Kev said he pinged them a few times but heard nothing back but may have another contact to connect with. See also https://support.mozilla.org/en-US/questions/916482#answer-304897
The problem actually seems to be resolved on the demo site despite no response to my ticket.

I'm not sure if this has been rolled out to all of their webmail servers (I assume they would have more than one) so if someone else can confirm it works on a different domain then we can probably resolve this bug.

silkphoenix, can you please test using Firefox 10 on your own webmail account?  If you are still redirected, try clearing your cookies and cache since the redirect may be cached.  If that doesn't work, try adding '?nocache' after the login.php in the URL (ie. http://mail.example.com/interfaces/sso/login.php?nocache) to bypass any caching.
(Assignee)

Comment 13

7 years ago
Matthew and Everyone else:

I updated to FF 10 and now all of my Network Solutions webmail accounts (I have three)are working normally. I guess NS did fix the problem.

PS: I didn't receive a response from my ticket either. Maybe NS got too many and just went ahead and fixed the problem silently.

Thank you for everyone's help.
Cool. I set the bug to RESOLVED/FIXED per comment 12 and 13. Reopen if you think it needs it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
For the record, NS replied this morning saying they are aware of the problem:
"We are aware of the issue with Firefox 10 on our webmail. Our Engineers are currently working to correct the issue we're sorry for the inconvenience."
(Assignee)

Comment 16

7 years ago
I received the same response from NS too.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.