Last Comment Bug 722917 - IonMonkey: TI is not enabled for ARM
: IonMonkey: TI is not enabled for ARM
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: ARM Linux
: -- normal (vote)
: ---
Assigned To: general
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-31 16:01 PST by Marty Rosenberg [:mjrosenb]
Modified: 2012-04-13 17:47 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
/home/mrosenberg/patches/turnOnTI-r0.patch (3.13 KB, patch)
2012-01-31 16:01 PST, Marty Rosenberg [:mjrosenb]
no flags Details | Diff | Review
change the location of a check to a more sane location (3.60 KB, patch)
2012-01-31 16:46 PST, Marty Rosenberg [:mjrosenb]
dvander: review+
Details | Diff | Review

Description Marty Rosenberg [:mjrosenb] 2012-01-31 16:01:20 PST
Created attachment 593255 [details] [diff] [review]
/home/mrosenberg/patches/turnOnTI-r0.patch

Looks like there was a typo in the old MacroAssembler that caused TI to never get turned on in my tests (or almost any other ARM tests).
Comment 1 Marty Rosenberg [:mjrosenb] 2012-01-31 16:46:14 PST
Created attachment 593266 [details] [diff] [review]
change the location of a check to a more sane location

dvander pointed out that (this == NULL) isn't valid C++, so I've pulled the check out to the calling functions.
Comment 2 David Anderson [:dvander] 2012-04-13 17:47:27 PDT
http://hg.mozilla.org/projects/ionmonkey/rev/d283b00c1f73

Note You need to log in before you can comment on or make changes to this bug.