codesize upload broken for SeaMonkey [and Thunderbird] due to tools dir being incorrect

RESOLVED FIXED

Status

Release Engineering
General
--
major
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Callek, Assigned: Callek)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 593270 [details] [diff] [review]
[buildbotcustom] v1

After porting Bug 561198 for SeaMonkey buildbot, I notice that we're failing to upload codesize (pack_scp not found).

Verifying the script is in the proper place in /tools I realize that its being called via a '../tools' which when a comm-central app is the project its based on, is the incorrect path. Solution is to make use of the WithProperties and toolsdir...

This patch does just that, and does it in all these places, rather than relying on magic knowledge of specifically where we put the toolsdir.
Attachment #593270 - Flags: review?(bhearsum)
Attachment #593270 - Flags: review?(bhearsum) → review+
(Assignee)

Comment 1

6 years ago
Comment on attachment 593270 [details] [diff] [review]
[buildbotcustom] v1

Thanks for the fast review!

http://hg.mozilla.org/build/buildbotcustom/rev/ad9e179c4a17

And pushed to seamonkey-production as a separate cset rather than doing a merge right now.

http://hg.mozilla.org/build/buildbotcustom/rev/fa72a6c9d8b8
Attachment #593270 - Flags: checked-in+
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.