Last Comment Bug 723040 - IonMonkey: Don't coerce comparison operands
: IonMonkey: Don't coerce comparison operands
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
Mentors:
Depends on:
Blocks: 677337
  Show dependency treegraph
 
Reported: 2012-02-01 02:37 PST by Jan de Mooij [:jandem]
Modified: 2012-02-01 12:03 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.94 KB, patch)
2012-02-01 02:45 PST, Jan de Mooij [:jandem]
no flags Details | Diff | Review
Patch (2.01 KB, patch)
2012-02-01 04:58 PST, Jan de Mooij [:jandem]
dvander: review+
Details | Diff | Review

Description Jan de Mooij [:jandem] 2012-02-01 02:37:48 PST

    
Comment 1 Jan de Mooij [:jandem] 2012-02-01 02:45:04 PST
Created attachment 593370 [details] [diff] [review]
Patch

Fixes v8-crypto. The problem was that "x == null" would return true instead of false if x is 0. Now we specialize as int32 if both operands are int32, and specialize as double if both operands are either int32 or double.
Comment 2 Jan de Mooij [:jandem] 2012-02-01 04:58:35 PST
Created attachment 593389 [details] [diff] [review]
Patch
Comment 3 Jan de Mooij [:jandem] 2012-02-01 12:03:28 PST
http://hg.mozilla.org/projects/ionmonkey/rev/06387601d4db

Note You need to log in before you can comment on or make changes to this bug.