Closed Bug 723061 Opened 9 years ago Closed 8 years ago

Use native look for arrow panels (doorhangers) on Mac

Categories

(Toolkit :: Themes, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 771284

People

(Reporter: enndeakin, Unassigned)

Details

Arrow panels currently have a black look on Mac. (Cocoa calls this the HUD look). Mac OS 10.7 UI guidelines have been updated to include this type of panel (called a popover in Cocoa terminology). You can see an example when adding an event in iCal.

See http://developer.apple.com/library/mac/#documentation/UserExperience/Conceptual/AppleHIGuidelines/Windows/Windows.html#//apple_ref/doc/uid/20000961-SW4

The suggestion is to use the grey look (called the minimal appearance) for most applications and the black look for media applications with a dark UI. I've never understood why we used a black look to begin with, so I think we should consider changing this.

I don't have the 10.7 sdk so I can't confirm, but there may a native theme api to draw the popover.
 
A further bug would to be implement the drag panel to a separate window feature as seen in iCal.
Keywords: uiwanted
(In reply to Neil Deakin from comment #0)

> The suggestion is to use the grey look (called the minimal appearance) for
> most applications and the black look for media applications with a dark UI.

> I've never understood why we used a black look to begin with, so I think we
> should consider changing this.

Until Lion OSX HUD overlays were styled with an inconsistent variety of slightly translucent/dark-grey depending on which app you happened to be in. That is largely what we pulled on when the identity and bookmark panels were designed for Firefox 3.

Updating the appearance of the arrow panels is part of the Australis theme work. We definitely want to update it to be lighter, more consistent with Lion and more consistent across platforms in general (see current Windows redesign work: http://people.mozilla.com/~shorlander/files/feature-pages/panels.jpg)


> I don't have the 10.7 sdk so I can't confirm, but there may a native theme
> api to draw the popover.

This would be pretty nice so we don't have to recreate the style. Some thoughts on this approach:

- Our arrow origination point is on either side of the panel and not the center

- We have a variety of UIs living in panels so it has to be flexible enough to accommodate those

- The native panels have animation and they use a background blur+transparency it might be odd if we directly copy the style but not those details


> A further bug would to be implement the drag panel to a separate window
> feature as seen in iCal.

That could be pretty awesome! :)
Component: XUL Widgets → Themes
QA Contact: xul.widgets → themes
Depends on: 771284
Considering that the description is to implement a native "look" aka theming, not necessarily using any native SDK, I think we've achieved that in bug 771284.
Marking as duplicate of that bug.
Status: NEW → RESOLVED
Closed: 8 years ago
No longer depends on: 771284
Resolution: --- → DUPLICATE
Duplicate of bug: 771284
You need to log in before you can comment on or make changes to this bug.