Last Comment Bug 723088 - Several invalid memory reporters when scrolling on 4walled
: Several invalid memory reporters when scrolling on 4walled
Status: RESOLVED FIXED
[MemShrink:P2]
:
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 711901
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-01 06:20 PST by Jakob
Modified: 2012-02-25 15:32 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
memory.txt (26.18 KB, text/plain)
2012-02-01 06:20 PST, Jakob
no flags Details
about:support file (7.45 KB, text/plain)
2012-02-01 07:54 PST, Jakob
no flags Details

Description Jakob 2012-02-01 06:20:12 PST
Created attachment 593423 [details]
memory.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120131 Firefox/12.0a1
Build ID: 20120131031150

Steps to reproduce:

Scrolled on http://4walled.org/search.php?tags=&board=&width_aspect=&searchstyle=larger&sfw=0&search=random for several minutes


Actual results:

Invalid memory reporters in about:memory
Comment 1 Jakob 2012-02-01 07:54:26 PST
Created attachment 593449 [details]
about:support file
Comment 2 Nicholas Nethercote [:njn] 2012-02-01 15:17:46 PST
Something is very wrong with the image accounting:

└──-1,461,278,897 B (-47.56%) -- images [?!]
   ├─────────255,420 B (00.01%) -- chrome
   │         ├──255,420 B (00.01%) -- used
   │         │  ├──255,420 B (00.01%) ── uncompressed-heap
   │         │  ├────────0 B (00.00%) ── raw
   │         │  └────────0 B (00.00%) ── uncompressed-nonheap
   │         └────────0 B (00.00%) -- unused
   │                  ├──0 B (00.00%) ── raw
   │                  ├──0 B (00.00%) ── uncompressed-heap
   │                  └──0 B (00.00%) ── uncompressed-nonheap
   └──-1,461,534,317 B (-47.57%) -- content [?!]
      ├──────────────75 B (00.00%) -- unused
      │              ├──43 B (00.00%) ── raw
      │              ├──32 B (00.00%) ── uncompressed-heap
      │              └───0 B (00.00%) ── uncompressed-nonheap
      └──-1,461,534,392 B (-47.57%) -- used [?!]
         ├─────132,857,269 B (04.32%) ── raw
         ├───────────────0 B (00.00%) ── uncompressed-nonheap
         └──-1,594,391,661 B (-51.89%) ── uncompressed-heap [?!]

"heap-unclassified" is an innocent bystander, because it's derived from other values including these bogus ones.
Comment 3 :aceman 2012-02-07 07:36:01 PST
Does it happen everytime you visit that page?

Have you tried Safe mode https://support.mozilla.com/en-US/kb/Safe+Mode ?
Comment 4 Justin Lebar (not reading bugmail) 2012-02-07 07:52:53 PST
Presumably it's reproducible if njn saw it.
Comment 5 Jakob 2012-02-07 07:55:36 PST
I can reproduce it in safe mode in 13.0a1 (2012-02-07), you have to keep scrolling to get a lot of images loaded, I use the End or Page down key for about 3-4 minutes, then I get the error, you also need to check about:memory before the images are discarded to see the error.
Comment 6 Justin Lebar (not reading bugmail) 2012-02-07 14:49:49 PST
(In reply to Justin Lebar [:jlebar] from comment #4)
> Presumably it's reproducible if njn saw it.

oh, njn was just looking at the attached about:memory output.
Comment 7 Jakob 2012-02-25 07:24:47 PST
I can no longer reproduce in 2012-02-23 and newer builds, 2012-02-22 fails. Maybe Bug 711901 fixed it?
Comment 8 Justin Lebar (not reading bugmail) 2012-02-25 10:41:19 PST
(In reply to Jakob from comment #7)
> I can no longer reproduce in 2012-02-23 and newer builds, 2012-02-22 fails.
> Maybe Bug 711901 fixed it?

Could be!  That change was merged on 2/22.
Comment 9 Nicholas Nethercote [:njn] 2012-02-25 15:32:57 PST
Oh, cool!  jlebar, I saw you marked bug 711901 as blocking this and my initial assumption was that it had caused a regression :)

Note You need to log in before you can comment on or make changes to this bug.