Last Comment Bug 723110 - crash _moz_cairo_scaled_font_destroy with gfx.canvas.azure.enabled=true on Linux
: crash _moz_cairo_scaled_font_destroy with gfx.canvas.azure.enabled=true on Linux
Status: RESOLVED FIXED
: crash
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86_64 Linux
: -- critical with 3 votes (vote)
: mozilla13
Assigned To: George Wright (:gw280) (:gwright)
:
Mentors:
: 723168 (view as bug list)
Depends on:
Blocks: 561361 702158 716121
  Show dependency treegraph
 
Reported: 2012-02-01 07:36 PST by Makoto Kato [:m_kato]
Modified: 2012-02-14 02:56 PST (History)
7 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make sure mScaledFont is initialised if USE_CAIRO is on (759 bytes, patch)
2012-02-01 11:52 PST, George Wright (:gw280) (:gwright)
jmuizelaar: review-
Details | Diff | Review
Refactor font code to lay the groundwork for having a ScaledFontFreetype class (8.71 KB, patch)
2012-02-01 13:29 PST, George Wright (:gw280) (:gwright)
jmuizelaar: review+
Details | Diff | Review

Description Makoto Kato [:m_kato] 2012-02-01 07:36:06 PST
When browse http://www.scirra.com/labs/perftest-2d/ with gfx.canvas.azure.enable=true, firefox for Linux crashes the following stack.


This bug was filed from the Socorro interface and is 
report bp-dad23233-c988-4cad-aa7c-eaaf12120201 .
============================================================= 
0 	libxul.so 	_moz_cairo_scaled_font_destroy 	gfx/cairo/cairo/src/cairo-scaled-font.c:1220
1 	libxul.so 	mozilla::gfx::ScaledFontBase::~ScaledFontBase 	gfx/2d/ScaledFontBase.cpp:92
2 	libxul.so 	mozilla::gfx::ScaledFontBase::~ScaledFontBase 	gfx/2d/ScaledFontBase.cpp:94
3 	libxul.so 	nsCanvasBidiProcessorAzure::DrawText 	content/canvas/src/nsCanvasRenderingContext2DAzure.cpp:3034
4 	libxul.so 	nsBidiPresUtils::ProcessText 	layout/base/nsBidiPresUtils.cpp:1824
5 	libxul.so 	nsCanvasRenderingContext2DAzure::DrawOrMeasureText 	content/canvas/src/nsCanvasRenderingContext2DAzure.cpp:3332
6 	libxul.so 	nsIDOMCanvasRenderingContext2D_FillText 	obj-firefox/js/xpconnect/src/dom_quickstubs.cpp:2535
7 	libxul.so 	js::InvokeKernel 	js/src/jscntxtinlines.h:311
8 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:2801
9 	libxul.so 	js::InvokeKernel 	js/src/jsinterp.cpp:537
10 	libxul.so 	js::Invoke 	js/src/jsinterp.h:157
11 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5452
12 	libxul.so 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:1973
13 	libxul.so 	nsGlobalWindow::RunTimeout 	dom/base/nsGlobalWindow.cpp:9375
14 	libxul.so 	nsGlobalWindow::TimerCallback 	dom/base/nsGlobalWindow.cpp:9763
15 	libxul.so 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:428
16 	libxul.so 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:524
17 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:657
18 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
19 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
20 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:208
21 	libxul.so 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:189
22 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:220
23 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3537
24 	firefox 	main 	browser/app/nsBrowserApp.cpp:205
25 	libc-2.13.so 	libc-2.13.so@0x2130c 	
26 	firefox 	firefox@0x1b9f
Comment 1 Marco Castelluccio [:marco] 2012-02-01 11:43:34 PST
This is a known problem of the font handling.
Comment 2 George Wright (:gw280) (:gwright) 2012-02-01 11:52:12 PST
Created attachment 593549 [details] [diff] [review]
Make sure mScaledFont is initialised if USE_CAIRO is on
Comment 3 Jeff Muizelaar [:jrmuizel] 2012-02-01 11:56:30 PST
Comment on attachment 593549 [details] [diff] [review]
Make sure mScaledFont is initialised if USE_CAIRO is on

Please implement ScaledFontFreetype and get rid of this constructor instead.
Comment 4 George Wright (:gw280) (:gwright) 2012-02-01 13:29:16 PST
Created attachment 593588 [details] [diff] [review]
Refactor font code to lay the groundwork for having a ScaledFontFreetype class
Comment 5 Marco Castelluccio [:marco] 2012-02-12 11:43:41 PST
Can we land this? With this bug resolved, we can test better Skia and if the performance is better than Cairo (and I think it is) we can switch to Skia by default.
Comment 6 Mozilla RelEng Bot 2012-02-13 06:59:10 PST
Autoland Patchset:
	Patches: 593588
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=a627a8131be2
Try run started, revision a627a8131be2. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=a627a8131be2
Comment 7 Mozilla RelEng Bot 2012-02-13 11:02:26 PST
Try run for a627a8131be2 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=a627a8131be2
Results (out of 209 total builds):
    success: 174
    warnings: 21
    failure: 14
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-a627a8131be2
Comment 8 Jeff Muizelaar [:jrmuizel] 2012-02-13 11:59:44 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/f7e4a21d261f
Comment 9 Marco Bonardo [::mak] 2012-02-14 02:28:11 PST
https://hg.mozilla.org/mozilla-central/rev/f7e4a21d261f
Comment 10 Marco Castelluccio [:marco] 2012-02-14 02:56:36 PST
*** Bug 723168 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.