Notify users that support for Win2k, XP RTM and XP SP1 are ending

RESOLVED DUPLICATE of bug 741004

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 741004
6 years ago
4 years ago

People

(Reporter: jpr, Unassigned)

Tracking

12 Branch
All
Windows XP
Points:
---

Firefox Tracking Flags

(firefox13-)

Details

(Reporter)

Description

6 years ago
Notify users that support for Win2k, XP RTM and XP SP1 are ending.  Possibly using the hotfix extension if we want to in the next 6 weeks, or uplifting to Aurora quickly.

Updated

6 years ago
Depends on: 563318
OS: Linux → Windows XP
Hardware: x86 → All
Version: unspecified → 12 Branch

Comment 1

6 years ago
Did I miss that (somewhere promised) discussion in Mozilla.dev.planning/platform when platforms are going to un-supported.
While I understand not wanting to "face that music" I think we owe those less fortunate users more than a popup message, or a refusal to update.

And, it would be nice to see the metrics data of how many users we will leaving behind.
BTW I fully understand the "why" of this, just not the "how".
Blocks: 467530

Comment 2

6 years ago
(In reply to Joe Sabash from comment #1)
> Did I miss that (somewhere promised) discussion

Read m.d.planning and m.d.a.firefox threads for the discussion, the metrics, and the outcome.

Comment 3

6 years ago
I don't think this notification needs to be rushed. We should give win2K users a prompt thanking them for using Firefox, letting them know that it's no longer supported, and linking them to Opera's download page.  We should give WinXP users a prompt telling them that their OS must be upgraded to be able to keep getting Firefox updates and pointing them to Microsoft's service pack download page.  

I don't think users really need time here. They have options and we should let them know what those options are. We're not saying "soon you'll need to buy a new computer" or anything like that.

Comment 4

6 years ago
(In reply to Joe Sabash from comment #1)
> Did I miss that (somewhere promised) discussion

There are possibly some others I've missed, but the main places to read:
https://groups.google.com/d/topic/mozilla.dev.platform/pvy2IQ-LPWI/discussion
https://groups.google.com/d/topic/mozilla.dev.apps.firefox/qwFkoDnkJeQ/discussion
http://weblogs.mozillazine.org/asa/archives/2012/01/end_of_firefox_win2k.html
Related: bug 684227
See Also: → bug 684227

Updated

6 years ago
tracking-firefox13: --- → +

Comment 6

6 years ago
Once Firefox 13 hits release, this page will need updating: 
https://wiki.mozilla.org/Firefox/Unsupported_OSes

Comment 7

6 years ago
(In reply to Asa Dotzler [:asa] from comment #3)
> We should
> give WinXP users a prompt telling them that their OS must be upgraded to be
> able to keep getting Firefox updates and pointing them to Microsoft's
> service pack download page.  

Er, just so you don't make a big gaffe here, if they haven't updated to SP3 by now, they are already permanently locked out of XP updates.

Comment 8

6 years ago
(In reply to VanillaMozilla from comment #7)
> (In reply to Asa Dotzler [:asa] from comment #3)
> > We should
> > give WinXP users a prompt telling them that their OS must be upgraded to be
> > able to keep getting Firefox updates and pointing them to Microsoft's
> > service pack download page.  
> 
> Er, just so you don't make a big gaffe here, if they haven't updated to SP3
> by now, they are already permanently locked out of XP updates.

Can you explain that? This page is a lie? http://technet.microsoft.com/en-us/windows/bb794714.aspx?ITPID=wtcfeed  I used Windows Update some months back to update a freshly installed XP system from the SP1 disk I had to SP3 with no problems.

Comment 9

6 years ago
Sorry, this is the better link http://windows.microsoft.com/en-US/windows/downloads/service-packs
I'm guessing we need some copy for the effected users and it sounds like we want to do this via some sort of pop-up message. 

If someone can boil down what the needs are and the final user experience, marketing can support this.
Forward duping to bug 741004 where the work is occurring.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
tracking-firefox13: + → -
Resolution: --- → DUPLICATE
Duplicate of bug: 741004
No longer blocks: 467530
No longer depends on: 563318
You need to log in before you can comment on or make changes to this bug.