Closed Bug 723202 Opened 10 years ago Closed 10 years ago

Thunderbird should open ICS email attachments in Lightning

Categories

(Calendar :: Lightning Only, defect)

x86_64
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 357480

People

(Reporter: travis.hardiman+bugzilla, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

Received an email with an ICS (calendar) attachment, I tried to open it with Thunderbird.


Actual results:

It just opened a new message window with the ICS file as an attachment.


Expected results:

It should have opened it in Lightning.
My question on superuser: http://superuser.com/questions/382022/how-do-i-get-thunderbird-to-open-an-ics-attachment-directly-in-lightnings-calen

Let me know if any more info is needed. (screenshots, sample ICS file, etc)
Moving to calendar as this is to do with the lightning add-on, not the core of Thunderbird.
Component: Message Reader UI → Lightning Only
Product: Thunderbird → Calendar
QA Contact: message-reader → lightning
Version: 10 → Trunk
A sample email (anonymized is ok) would be nice.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 357480
Here is a sample email :


From: Capitaine Train <calendrier@capitainetrain.com>
To: XXX.XXXXX@XXXXXXX.com
Message-ID: <50ac07b0f49f_46c632a6e020305d@sa4.prod.capitainetrain.com.mail>
Subject: =?UTF-8?Q?=C3=89v=C3=A8nement_pour_votre_trajet_Toulouse_=E2=86=92?=
 =?UTF-8?Q?_Paris_=2825_nov._13:38=29?=
Mime-Version: 1.0
Content-Type: multipart/alternative;
 boundary="--==_mimepart_50ac07b0c9ef_46c632a6e020272e";
 charset=UTF-8
Content-Transfer-Encoding: 7bit



----==_mimepart_50ac07b0c9ef_46c632a6e020272e
Date: Tue, 20 Nov 2012 23:44:00 +0100
Mime-Version: 1.0
Content-Type: text/plain;
 charset=UTF-8
Content-Transfer-Encoding: quoted-printable
Content-ID: <50ac07b0e542_46c632a6e0202893@sa4.prod.capitainetrain.com.mail>

XXX,

Vous trouverez ci-joint l'=C3=A9v=C3=A8nement .ics =C3=A0 ajouter =C3=A0 =
votre calendrier pour le trajet XXXX =E2=86=92 XXXX.

Ceci n'est pas un billet. Vous devez voyager avec vos titres de transport=
s, et justificatifs de r=C3=A9duction =C3=A9ventuels.

Si vous ne souhaitez plus recevoir les =C3=A9v=C3=A8nements .ics, vous po=
uvez les d=C3=A9sactiver dans vos pr=C3=A9f=C3=A9rences sur le site Capit=
aine Train.

Capitaine Train
https://app.capitainetrain.com/


----==_mimepart_50ac07b0c9ef_46c632a6e020272e
Date: Tue, 20 Nov 2012 23:44:00 +0100
Mime-Version: 1.0
Content-Type: text/calendar;
 charset=UTF-8;
 method=REQUEST
Content-Transfer-Encoding: quoted-printable
Content-ID: <50ac07b0ee38_46c632a6e0202972@sa4.prod.capitainetrain.com.mail>

BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//com.capitainetrain/Tickets 1.0//EN
CALSCALE:GREGORIAN
METHOD:REQUEST
BEGIN:VEVENT
DTEND;VALUE=3DDATE-TIME:20121125T190700Z
STATUS:TENTATIVE
DTSTART;VALUE=3DDATE-TIME:20121125T123800Z
TRANSP:TRANSPARENT
DTSTAMP;VALUE=3DDATE-TIME:20121120T224400Z
ATTENDEE;CUTYPE=3DINDIVIDUAL;ROLE=3DREQ-PARTICIPANT;PARTSTAT=3DNEEDS-ACTI=
ON;RSV
 P=3DTRUE;X-NUM-GUESTS=3D0;CN=3DR=C3=A9my XXX:MAILTO:XXX.XXXXX@X=
XXX.com
UID:c545ae1156ad9284fdde9018af3024c6080653d2@capitainetrain.com
DESCRIPTION:Comment obtenir votre billet=C2=A0?\n------------------------=
----
 --\n\n
SUMMARY:XXXX
ORGANIZER;CN=3DCapitaine Train:MAILTO:calendrier@capitainetrain.com
LOCATION:XXXX
SEQUENCE:0
END:VEVENT
END:VCALENDAR


----==_mimepart_50ac07b0c9ef_46c632a6e020272e--
Unfortunatelly I mention, that this bug is still open. Does anyone has a workaround to tell thunderbird and lightning to handle .ics-events? On some of our machines in the company inventions to events work, on some other it doesn't.
I also wait for a workaround. It's quite frustrating to save the ICS file and then drag & drop it onto "Today Pane" ie. the Events panel as suggested here: https://superuser.com/a/469978/139893

I second the last comments. I can download an ics file from a web application (indico) for events/meeting agendas. It would be such a simplification if I could add meetings to my calendar by just clicking on the link ics file and opening the file with thunderbird. Now thunderbird just creates a new message with the ics file as attachment. Dowloading & importing the file are too many steps to to integrate it efficiently in the daily work flow. My window manager (i3) has no desktop, therefore using the drag&drop solution suggested here and there also does not help.

Interestingly, let's say I create an event in Zoom (or whatever), send event to Google calendar, and invite myself (to get an email with .ics attached) - this email displays the details of the event in message body, it has .ics file attached and the event can be added to calendar.
But when I take the attached .ics file, save it to disk, and attach it to another email - it does not display as an event in Thunderbird (cannot be added to calendar directly, needs to be drag-and-dropped to 'today' pane to work. When I open the same email with the .ics file attached in another email client (aquamail on my android phone) everything works ok.
I can send such a not-working email with .ics attachment to whoever asks.

With increasing use of .ics files across a wide range of online services (Zoom, EventBrite, Doodle others), this functionality is now making Thunderbird irritatingly out of touch.

If Thunderbird already has all the plumbing to handle .ics files when opened directly through menus or drag-and-drop, then it should be quite straightforward to implement a file association that allows .ics files download in Firefox to be directly opened and acted on in Thunderbird.

Please could this functionality be prioritised a bit higher?

Flags: needinfo?(ssitter)

(In reply to John Pye from comment #11)
Please do not CC random people on closed bugs to get information that you can get on your own if you read the bug. This bug is marked as a duplicate of Bug 357480 that is fixed/implemented in Thunderbird 84 Beta and newer. Therefor it will be part of the next major Thunderbird release.

Flags: needinfo?(ssitter)
You need to log in before you can comment on or make changes to this bug.