Last Comment Bug 723217 - White boxes instead of plugin content after tapping to play
: White boxes instead of plugin content after tapping to play
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla13
Assigned To: Josh Aas
:
Mentors:
: 723503 (view as bug list)
Depends on:
Blocks: 90268
  Show dependency treegraph
 
Reported: 2012-02-01 11:19 PST by :Margaret Leibovic
Modified: 2012-03-19 08:57 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (17.65 KB, patch)
2012-02-09 15:38 PST, Josh Aas
snorp: review+
Details | Diff | Review

Description :Margaret Leibovic 2012-02-01 11:19:27 PST
I'm seeing this on: http://people.mozilla.org/~mwargers/tests/plugins/flash/flashembed.html.

I thought it was happening on all sites, but some sites partially work. On http://www.adobe.com/software/flash/about/ the top banner will play correctly, but the smaller element in the bottom right won't. Also, on http://www.dairyqueen.com, the "How do you DQ?" banner and the menu below will show up, but the content in the middle of the framed area doesn't appear.
Comment 1 :Margaret Leibovic 2012-02-02 10:26:22 PST
Works for me with latest m-c now.
Comment 2 Doug Turner (:dougt) 2012-02-02 10:50:57 PST
*** Bug 723503 has been marked as a duplicate of this bug. ***
Comment 3 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-02-02 13:02:49 PST
Currently busted for me on m-c under Froyo, at least.
Comment 4 :Margaret Leibovic 2012-02-02 14:31:50 PST
(In reply to Margaret Leibovic [:margaret] from comment #1)
> Works for me with latest m-c now.

Ah, I'm dumb and installed the wrong APK. Yeah, still busted on Gingerbread :(
Comment 5 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-02-02 14:50:38 PST
Regression from bug 90268?
Comment 6 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-02-09 10:20:16 PST
To clarify, this is busted on all versions of Android. Not just Froyo.
Comment 7 Josh Aas 2012-02-09 15:38:08 PST
Created attachment 595888 [details] [diff] [review]
fix v1.0

The first part of the fix is cutting off instantiation at a better place when the user has not clicked yet. The second part is letting stream data get delivered after instantiation. I couldn't resist cleaning up the click-to-play implementation to not pass its state variable all over the place.
Comment 8 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-02-09 18:10:46 PST
Comment on attachment 595888 [details] [diff] [review]
fix v1.0

Review of attachment 595888 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me
Comment 9 Josh Aas 2012-02-09 18:18:29 PST
Try run:

https://tbpl.mozilla.org/?tree=Try&rev=49e74dea72a1
Comment 10 Josh Aas 2012-02-10 05:40:57 PST
pushed to mozilla-inbound

http://hg.mozilla.org/integration/mozilla-inbound/rev/40c36f6068d6
Comment 11 Ed Morley [:emorley] 2012-02-10 19:43:10 PST
https://hg.mozilla.org/mozilla-central/rev/40c36f6068d6
Comment 12 Gabriela [:gaby2300] 2012-03-15 16:36:13 PDT
I can still see this bug in Galaxy S 2, Android 2.3.4 and build 20120315
Comment 13 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-03-19 06:20:30 PDT
There appears to be a problem with full page plugins. This bug already has a patch that was committed, though, so I've opened a new bug for this, 736998.
Comment 14 Philip Chee 2012-03-19 08:57:45 PDT
Linkify Bug 736998

Note You need to log in before you can comment on or make changes to this bug.