Last Comment Bug 723219 - disable JS Set and Map before Firefox (12) Beta cycle
: disable JS Set and Map before Firefox (12) Beta cycle
Status: RESOLVED FIXED
[qa-]
: dev-doc-complete
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: 12 Branch
: All All
: -- normal (vote)
: ---
Assigned To: Jason Orendorff [:jorendorff]
:
: Jason Orendorff [:jorendorff]
Mentors:
: 721916 (view as bug list)
Depends on:
Blocks: 697479
  Show dependency treegraph
 
Reported: 2012-02-01 11:20 PST by Christopher Blizzard (:blizzard)
Modified: 2012-05-01 10:53 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
-


Attachments

Description Christopher Blizzard (:blizzard) 2012-02-01 11:20:40 PST
We added some experimental JS features to trunk, and we want people to test them during the Aurora cycle, but we don't want to leak them onto the web before they are ready.  So we want to disable them during or before the beta process for Firefox 12.
Comment 1 David Mandelin [:dmandelin] 2012-03-06 15:40:11 PST
Jason, can you grab this?
Comment 2 Alex Keybl [:akeybl] 2012-03-13 12:04:34 PDT
It's not clear to me if this is just a simple backout of 

https://hg.mozilla.org/mozilla-central/rev/6a5e20a0f741
https://hg.mozilla.org/mozilla-central/rev/51f43afa160e

on FF12 or something more complicated. Please confirm ASAP since we're performing the merge as I'm writing this.
Comment 3 Jason Orendorff [:jorendorff] 2012-03-13 12:14:00 PDT
Yes, that should do it. If it doesn't, ping me and we can work through whatever issues come up. It should be straightforward; this stuff is a pure library feature that nothing is depending on yet.
Comment 5 Alex Keybl [:akeybl] 2012-04-09 15:55:30 PDT
We're continuing to track for FF13 in case we need to disable JS map and set for that release as well.
Comment 6 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2012-04-17 02:02:27 PDT
*** Bug 721916 has been marked as a duplicate of this bug. ***
Comment 7 Marco Bonardo [::mak] 2012-04-24 16:18:08 PDT
mdn still states these are available in firefox 12, should be updated.
Comment 8 David Mandelin [:dmandelin] 2012-04-24 18:28:49 PDT
(In reply to Marco Bonardo [:mak] from comment #7)
> mdn still states these are available in firefox 12, should be updated.

Thanks for the note--I bumped the min version to 14 in both MDN docs.
Comment 9 Jean-Yves Perrier [:teoli] 2012-04-24 18:55:00 PDT
David, Marco: sorry about that. It is very difficult for us to know when something is backed out in the Aurora or Beta phase. We usually follow the original bug, which stay RESOLVED / FIXED, but not the back-out bug (like this one).

So when a backout/disabling of a new feature happens, please add the dev-doc-needed to one of the two bugs (original or new one). That gives us a chance to see it. :-) 

(I set the keyword to dev-doc-complete here, so that we know it has been handled. Thanks David!)
Comment 10 Marco Bonardo [::mak] 2012-04-25 05:11:48 PDT
I actually saw some articles about the FF12 release saying it includes Sets and Maps, and checking the release notes, we stated they are in the product :( (http://www.mozilla.org/en-US/firefox/12.0/releasenotes/)
Comment 11 Alex Keybl [:akeybl] 2012-04-25 14:50:29 PDT
(In reply to Marco Bonardo [:mak] from comment #10)
> I actually saw some articles about the FF12 release saying it includes Sets
> and Maps, and checking the release notes, we stated they are in the product
> :( (http://www.mozilla.org/en-US/firefox/12.0/releasenotes/)

I've fixed this now. We're going to do a better job of double checking our release notes ahead of our next release.

http://viewvc.svn.mozilla.org/vc?view=revision&revision=104777
Comment 12 dynamis (Tomoya ASAI) 2012-04-26 03:29:47 PDT
Should we remove description about Set/Map from this page
https://developer.mozilla.org/en/Firefox_12_for_developers#JavaScript
and add to Firefox 14 page?
https://developer.mozilla.org/en/Firefox_14_for_developers
# if we will not disable Set/Map on 13beta, we should add to Firefox 13 page
Comment 13 Eric Shepherd [:sheppy] 2012-04-27 09:45:38 PDT
It's removed from the Firefox 12 page and on the Firefox 14 page. If someone can tell me if they'll be disabled or not in 13, that would help.
Comment 14 Eric Shepherd [:sheppy] 2012-04-27 09:45:58 PDT
That is, they're now listed on the Firefox 14 page.
Comment 15 Alex Vincent [:WeirdAl] 2012-04-27 09:58:21 PDT
At present, they're available in FF13 beta.  I had an IRC conversation with Jason shortly before the last FF train departure, and the consensus was to leave it in.  The reason:  the API is about 85% stable now.
Comment 16 Alex Keybl [:akeybl] 2012-05-01 10:53:57 PDT
(In reply to Alex Vincent [:WeirdAl] from comment #15)
> At present, they're available in FF13 beta.  I had an IRC conversation with
> Jason shortly before the last FF train departure, and the consensus was to
> leave it in.  The reason:  the API is about 85% stable now.

Given that, untracking for FF13.

Note You need to log in before you can comment on or make changes to this bug.