Last Comment Bug 723221 - Properly premultiply during JPG encode/decode
: Properly premultiply during JPG encode/decode
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla13
Assigned To: Jeff Gilbert [:jgilbert]
:
Mentors:
Depends on:
Blocks: 713143
  Show dependency treegraph
 
Reported: 2012-02-01 11:27 PST by Jeff Gilbert [:jgilbert]
Modified: 2012-03-12 16:31 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Premultiply JPG data correctly (4.31 KB, patch)
2012-02-01 11:28 PST, Jeff Gilbert [:jgilbert]
joe: review+
Details | Diff | Review
Premultiply JPG data correctly (4.66 KB, patch)
2012-02-08 16:28 PST, Jeff Gilbert [:jgilbert]
jgilbert: review+
Details | Diff | Review

Description Jeff Gilbert [:jgilbert] 2012-02-01 11:27:24 PST
Parent bug is Bug 713143.
Comment 1 Jeff Gilbert [:jgilbert] 2012-02-01 11:28:28 PST
Created attachment 593537 [details] [diff] [review]
Premultiply JPG data correctly

Clean try run at: https://tbpl.mozilla.org/?tree=Try&rev=334cf17cf17e
Comment 2 Joe Drew (not getting mail) 2012-02-01 19:07:20 PST
Comment on attachment 593537 [details] [diff] [review]
Premultiply JPG data correctly

Review of attachment 593537 [details] [diff] [review]:
-----------------------------------------------------------------

This is fine; I presume you decided not to use GFX_PREMULTIPLY because you're unifying all (un)premultiplication in a separate bug?
Comment 3 Jeff Gilbert [:jgilbert] 2012-02-08 16:28:59 PST
Created attachment 595577 [details] [diff] [review]
Premultiply JPG data correctly

I forgot that gfxColor.h had an individual GFX_PREMULTIPLY. It's a worse approximation, but at least it's consistent. 

Changed that and pushed back to try. Carrying forward r+ unless the trypush collapses.

https://tbpl.mozilla.org/?tree=Try&rev=029660d930a6
Comment 5 Jeff Gilbert [:jgilbert] 2012-03-12 16:31:20 PDT
Looks like this got skipped over:
https://hg.mozilla.org/mozilla-central/rev/308b3ced990b

Note You need to log in before you can comment on or make changes to this bug.