Last Comment Bug 723232 - nsHTMLEditRules::RelativeChangeIndentationOfElementNode removes divs with any one attribute
: nsHTMLEditRules::RelativeChangeIndentationOfElementNode removes divs with any...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: :Ms2ger
:
Mentors:
Depends on: 724259
Blocks: 724261
  Show dependency treegraph
 
Reported: 2012-02-01 11:42 PST by :Ms2ger
Modified: 2012-02-10 04:31 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.05 KB, patch)
2012-02-01 11:42 PST, :Ms2ger
no flags Details | Diff | Splinter Review
Patch v2 (1.71 KB, patch)
2012-02-04 04:15 PST, :Ms2ger
ehsan: review+
Details | Diff | Splinter Review

Description :Ms2ger 2012-02-01 11:42:54 PST
Created attachment 593545 [details] [diff] [review]
Patch v1

... unless that attribute is |style|. If you want a test, you'll have to write it yourself, I'm afraid.
Comment 1 Mozilla RelEng Bot 2012-02-01 12:22:35 PST
Autoland Patchset:
	Patches: 593545
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/rev/c59f7f7e668c
Try run started, revision c59f7f7e668c. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=c59f7f7e668c
Comment 2 Mozilla RelEng Bot 2012-02-01 12:30:21 PST
Try run for 77b6037385fe is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=77b6037385fe
Results (out of 14 total builds):
    exception: 14
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-77b6037385fe
Comment 3 Mozilla RelEng Bot 2012-02-01 12:30:25 PST
Try run for 7093ca8965ac is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=7093ca8965ac
Results (out of 14 total builds):
    exception: 14
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-7093ca8965ac
Comment 4 Mozilla RelEng Bot 2012-02-01 16:15:18 PST
Try run for c59f7f7e668c is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=c59f7f7e668c
Results (out of 206 total builds):
    exception: 2
    success: 169
    warnings: 35
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-c59f7f7e668c
Comment 5 :Ehsan Akhgari 2012-02-02 12:04:19 PST
Comment on attachment 593545 [details] [diff] [review]
Patch v1

See the failures here: https://tbpl.mozilla.org/php/getParsedLog.php?id=9015625&tree=Try#error0

This tells me that the div in this test has a single attribute which is not a style attribute.  Can you please print it out to see what it is?  The thing that the test is testing for is the desired behavior, but I'm curious to know why it breaks with this patch.
Comment 6 :Ms2ger 2012-02-04 02:24:20 PST
Ah, interesting. It's _moz_dirty. Now to figure out why my cleanup fixes it...
Comment 7 :Ms2ger 2012-02-04 02:59:54 PST
Alright, that's because I suck at boolean logic.
Comment 8 :Ms2ger 2012-02-04 04:15:56 PST
Created attachment 594423 [details] [diff] [review]
Patch v2
Comment 9 Mozilla RelEng Bot 2012-02-04 04:20:09 PST
Autoland Patchset:
	Patches: 594423
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/rev/2a10ad08202c
Try run started, revision 2a10ad08202c. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=2a10ad08202c
Comment 10 Mozilla RelEng Bot 2012-02-04 06:00:36 PST
Try run for 2a10ad08202c is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=2a10ad08202c
Results (out of 14 total builds):
    exception: 12
    failure: 2
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-2a10ad08202c

Note You need to log in before you can comment on or make changes to this bug.