Last Comment Bug 723349 - Fix params in addTab on session restore failure
: Fix params in addTab on session restore failure
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: Firefox 13
Assigned To: Brian Nicholson (:bnicholson) (PTO through August 1)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-01 16:37 PST by Brian Nicholson (:bnicholson) (PTO through August 1)
Modified: 2012-02-07 01:46 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
fixed


Attachments
patch (1.15 KB, patch)
2012-02-01 16:45 PST, Brian Nicholson (:bnicholson) (PTO through August 1)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Brian Nicholson (:bnicholson) (PTO through August 1) 2012-02-01 16:37:31 PST
>diff --git a/mobile/android/chrome/content/browser.js b/mobile/android/chrome/content/browser.js
>       // Be ready to handle any restore failures by making sure we have a valid tab opened
>       let restoreCleanup = {
>         observe: function(aSubject, aTopic, aData) {
>           Services.obs.removeObserver(restoreCleanup, "sessionstore-windows-restored");
>           if (aData == "fail") {
>             let params = { selected: restoreToFront };
>             BrowserApp.addTab("about:home", { showProgress: false });
>           }

The params variable isn't used here (looks like I forgot to pass it to addTab in bug 592328).
Comment 1 Brian Nicholson (:bnicholson) (PTO through August 1) 2012-02-01 16:38:57 PST
CC'ing margaret since she added the showProgress param.
Comment 2 Brian Nicholson (:bnicholson) (PTO through August 1) 2012-02-01 16:45:27 PST
Created attachment 593655 [details] [diff] [review]
patch

Remove "params" variable and add "selected" to addTab() params.
Comment 3 Brian Nicholson (:bnicholson) (PTO through August 1) 2012-02-01 17:52:35 PST
Landed on inbound:
http://hg.mozilla.org/integration/mozilla-inbound/rev/252293f10484
Comment 4 Brian Nicholson (:bnicholson) (PTO through August 1) 2012-02-01 21:27:32 PST
Comment on attachment 593655 [details] [diff] [review]
patch

[Approval Request Comment]
Fixes bug where externally loaded URL may not be selected if doing a session restore. Low risk.
Comment 5 Brian Nicholson (:bnicholson) (PTO through August 1) 2012-02-01 23:55:36 PST
(In reply to Brian Nicholson (:bnicholson) from comment #0)
> The params variable isn't used here (looks like I forgot to pass it to
> addTab in bug 592328).

Erm, that's bug 701092. Slightly off.
Comment 6 Alex Keybl [:akeybl] 2012-02-02 06:44:37 PST
Comment on attachment 593655 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Comment 7 Ed Morley [:emorley] 2012-02-02 06:56:48 PST
https://hg.mozilla.org/mozilla-central/rev/252293f10484
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2012-02-06 12:53:14 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/fefd5adb4134
Comment 9 Brad Lassey [:blassey] (use needinfo?) 2012-02-06 19:33:33 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/b20fd923081b
Comment 10 Cristian Nicolae (:xti) 2012-02-07 01:46:50 PST
Verified fixed on:

Firefox 13.0a1 (2012-02-06)
20120206031148
http://hg.mozilla.org/mozilla-central/rev/814d0b2dbaba
Device: HTC Desire Z
OS: Android 2.3.3

Firefox 12.0a2 (2012-02-06)
20120206042011
http://hg.mozilla.org/releases/mozilla-aurora/rev/9fb0c06ceb49
Device: HTC Desire Z
OS: Android 2.3.3

Firefox 11.0
20120206202409
http://hg.mozilla.org/releases/mozilla-beta/rev/1c0aba74d116
Device: HTC Desire Z
OS: Android 2.3.3

Note You need to log in before you can comment on or make changes to this bug.