Last Comment Bug 723525 - Mark classes final or add virtual destructor in content/*
: Mark classes final or add virtual destructor in content/*
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla13
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-02 07:52 PST by Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
Modified: 2012-02-03 11:19 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Mark classes final or add virtual destructor in content/* (4.57 KB, patch)
2012-02-02 07:52 PST, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
jmuizelaar: review+
Details | Diff | Review

Description Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-02 07:52:14 PST
Created attachment 593840 [details] [diff] [review]
Mark classes final or add virtual destructor in content/*

Currently builds with --enable-warnings-as-errors are broken with clang because of the warning/error

error: delete called on 'fooBar' that has virtual functions but non-virtual destructor [-Werror,-Wdelete-non-virtual-dtor]

This patch fixes some of them.
Comment 1 Jeff Muizelaar [:jrmuizel] 2012-02-02 08:01:39 PST
Comment on attachment 593840 [details] [diff] [review]
Mark classes final or add virtual destructor in content/*

I'm not a content peer, so I'm probably not the best reviewer for this. That being said I've submitted patches like this before and have never received any negative feedback so it's probably safe.
Comment 2 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-02 08:17:41 PST
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=f60a70c9120f
Comment 3 Ed Morley [:emorley] 2012-02-03 11:19:53 PST
https://hg.mozilla.org/mozilla-central/rev/f60a70c9120f

Note You need to log in before you can comment on or make changes to this bug.