Closed Bug 723617 Opened 8 years ago Closed 8 years ago

Re-fire PluginClickToPlay events on pageshow

Categories

(Core :: Plug-ins, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Margaret, Assigned: jaws)

Details

This is a follow-up to bug 719875. When we load pages from the cache, we un-freeze plugins that were already playing, but if a plugin hasn't been clicked-to-play, we don't get an event letting us know about it. There are some workarounds available on the front-end side, but getting this event again would give us the cleanest solution.
Assignee: nobody → jwein
Status: NEW → ASSIGNED
I can't reproduce this bug.

I used the following steps:
0) Apply the patch from bug 711552
1) Add a dump() statement to the event handler for "PluginClickToPlay" in /browser/base/content/browser.js
2) Open http://people.mozilla.org/~mwargers/tests/plugins/flash/
3) Open http://people.mozilla.org/~mwargers/tests/plugins/flash/flashembed.html
4) Activate the plugins
5) Open the Web Console
6) Web Developer -> Work Offline
7) Hit back button
8) Hit forward button
9) Notice that there is no network traffic and the click-to-play overlay still shows
10) Activate the plugins

This works and doesn't show any network traffic, so by that I am assuming that the page is loading from cache and the dump statements are still printing to the console.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
My last sentence reads a little confusing. I'm not "assuming that the dump statements are being printed to the console" lol, the dump statements *are* being printed to the console. Apologies if I confused anybody.
According to https://bugzilla.mozilla.org/show_bug.cgi?id=730318#c9, this is not fixed.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
There is a difference here between desktop and mobile. The event doesn't refire on mobile.
Summary: Re-fire PluginClickToPlay events on back/forward navigation → Re-fire PluginClickToPlay events on pageshow
This bug will not be necessary since the work that is being done in bug 730318 will provide a better solution.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.