Last Comment Bug 723618 - compile errors on Mac OS X 10.7 targeting 10.6 SDK
: compile errors on Mac OS X 10.7 targeting 10.6 SDK
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: mozilla13
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
:
: Milan Sreckovic [:milan]
Mentors:
: 723738 (view as bug list)
Depends on:
Blocks: 715785
  Show dependency treegraph
 
Reported: 2012-02-02 10:47 PST by Josh Aas
Modified: 2012-02-03 11:01 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
build log (7.43 KB, text/plain)
2012-02-02 10:47 PST, Josh Aas
no flags Details
remove forward declaration (4.07 KB, patch)
2012-02-02 15:56 PST, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
b56girard: review+
Details | Diff | Splinter Review

Description Josh Aas 2012-02-02 10:47:14 PST
Created attachment 593901 [details]
build log

Full log attached.

In file included from /Users/josh/src/mozilla/ff_trunk_debug_x86_64/dom/plugins/ipc/PluginUtilsOSX.mm:42:
In file included from /Users/josh/src/mozilla/ff_trunk_debug_x86_64/dom/plugins/ipc/PluginUtilsOSX.h:45:
In file included from ../../../dist/include/nsCoreAnimationSupport.h:49:
../../../dist/include/nsIOSurface.h:48:7: error: redefinition of 'NSOpenGLContext' as different kind of symbol
class NSOpenGLContext;
Comment 1 Gregory Szorc [:gps] 2012-02-02 11:21:43 PST
I'm seeing this as well. I also fingered bug 715785 as the root cause. Although, I haven't proved it.

This is the first time I haven't been able to build with the 10.7 SDK since 10.7 first came out (July 2011). Is backing out https://hg.mozilla.org/mozilla-central/rev/67b0e13d7a62 justified?
Comment 2 Joe Drew (not getting mail) 2012-02-02 11:54:40 PST
No, but we can fix this instead :)
Comment 3 Joe Drew (not getting mail) 2012-02-02 15:28:03 PST
*** Bug 723738 has been marked as a duplicate of this bug. ***
Comment 4 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-02 15:54:22 PST
I added a patch to bug 723738.
Should I just move it here?
Comment 5 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-02 15:56:09 PST
Created attachment 593996 [details] [diff] [review]
remove forward declaration

With this forward declaration the code reduces to

@interface NSOpenGLContext {
}
@end
class NSOpenGLContext;

which gcc accepts but clang intentionally rejects.

https://tbpl.mozilla.org/?tree=Try&rev=b8b6eed5b818
Comment 6 Benoit Girard (:BenWa) 2012-02-02 16:04:59 PST
Comment on attachment 593996 [details] [diff] [review]
remove forward declaration

I can review this. r+
Comment 7 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-02-02 16:24:51 PST
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=8c6eab735db2
Comment 8 Ed Morley [:emorley] 2012-02-03 11:01:27 PST
https://hg.mozilla.org/mozilla-central/rev/8c6eab735db2

Note You need to log in before you can comment on or make changes to this bug.