Firefox crashing when applying XBL with empty method

RESOLVED FIXED in mozilla13

Status

()

Core
XBL
--
critical
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Gleb M. Borisov, Assigned: Neil Deakin (not available until Aug 9))

Tracking

({crash, testcase})

10 Branch
mozilla13
x86
Mac OS X
crash, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 593943 [details]
XPI with test case. Press CrashMe to reproduce

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_2) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7

Steps to reproduce:

Attaching XBL via elem.style.MozBinding = 'url(...)'


Actual results:

Firefox Crash


Expected results:

XBL should be attached
(Reporter)

Comment 1

6 years ago
Created attachment 593944 [details]
Testcase sources

Check case1.xul to see how XBL is applied and case1.xml to see XBL itself. Browser is crashing while loading XBL document.
(Reporter)

Comment 2

6 years ago
This issue is similiar to 199851, but I think a lot of things changed since 2003.
(Reporter)

Updated

6 years ago
Crash Signature: bp-4c224926-f9c9-4228-b188-281302120202
See Also: → bug 199851

Comment 3

6 years ago
Can you provide a link to the corresponding crash report from about:crashes?
(Reporter)

Comment 4

6 years ago
Yep, of course: https://crash-stats.mozilla.com/report/index/bp-4c224926-f9c9-4228-b188-281302120202
This looks like a null-deref crash due to XBL fastload.  Are we trying to write out a null function object or something?
Blocks: 94199
Status: UNCONFIRMED → NEW
Component: Untriaged → XBL
Ever confirmed: true
Product: Firefox → Core
QA Contact: untriaged → xbl
Crash Signature: bp-4c224926-f9c9-4228-b188-281302120202 → [@ JS_XDRFunctionObject ]

Updated

6 years ago
Severity: normal → critical
Keywords: crash, testcase
Created attachment 595501 [details] [diff] [review]
null check for method
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #595501 - Flags: review?(bzbarsky)
Comment on attachment 595501 [details] [diff] [review]
null check for method

r=me
Attachment #595501 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/mozilla-central/rev/a98cf6ce2f0a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.