Closed Bug 723697 Opened 8 years ago Closed 8 years ago

Firefox ignore "automatic open torrent file" option since ver. 3.5

Categories

(Firefox :: Untriaged, defect, minor)

9 Branch
x86
Windows 7
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 453455

People

(Reporter: maindeveloper.in, Unassigned)

References

()

Details

(Whiteboard: torrent, uTorrent, automaticly, options,download)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:9.1) Gecko/20120121 Firefox/9.1 PaleMoon/9.1
Build ID: 20120121215457

Steps to reproduce:

When I'm downloading torrent file I choose option: "Open torrent file automaticly in uTorrent" but open dialog always appears again and again, always. This bug exist since Firefox 3.5, I posteted it one year ago on Ukrainian mozilla forum http://mozilla-forum.org.ua/index.php?topic=760.msg3350#msg3350 (there are screenshots). 


Actual results:

Firefox always ask me what I want to do:
1. Open File with uTorrent
2. Save file

and yes I twice check rules; check, unckeck checkbox - Automatcly remember my choise. I reinstall windows, upgrade from xp to windows 7. And I have this bug on my laptop, desktop and work PC since ver. 3.5.


Expected results:

Firefox should to open file in uTorrent and don't ask me about this.
Severity: normal → minor
Priority: -- → P2
Whiteboard: torrent, uTorrent, automaticly, options,download
Please provide an URL to such a .torrent file. 
This is basically no bug if the site either sends the file as application/octet-stream or with a content-disposition:attachment header
Priority: P2 → --
I'm using BitTorrent protocol all the time and I didn't find any "valid" site that works properly for more than one year.

Torrent file:
http://releases.ubuntu.com/11.10/ubuntu-11.10-desktop-amd64.iso.torrent
http://tfile.ru/forum/download.php?id=506145&uk=1111111111

All torrent files from sites (really all):
http://thepiratebay.se/
http://www.ubuntu.com/download/ubuntu/alternative-download#bt
>http://tfile.ru/forum/download.php?id=506145&uk=1111111111 :
>Content-Disposition:	attachment; filename="22_puli_bessmertnyj_[tfile.ru].torrent"

They send an attachment header that forces a save dialog. The decision for for the content-type "application/x-bittorrent" is saved but not used with such a header.

>http://releases.ubuntu.com/11.10/ubuntu-11.10-desktop-amd64.iso.torrent
This file should work and should use the saved decision.
(In reply to Matthias Versen (Matti) from comment #3)
> >http://tfile.ru/forum/download.php?id=506145&uk=1111111111 :
> >Content-Disposition:	attachment; filename="22_puli_bessmertnyj_[tfile.ru].torrent"
> 
> They send an attachment header that forces a save dialog. The decision for
> for the content-type "application/x-bittorrent" is saved but not used with
> such a header.

For me, as a user, it's absolutely doesn't matter, but what can I do in this situation to turn on automatically download and open torrent files without save dialog?
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 453455
Workaround: Install the extension from
https://addons.mozilla.org/en-US/firefox/addon/inlinedisposition/
Thx, I was waiting for it few years
You need to log in before you can comment on or make changes to this bug.