Last Comment Bug 723711 - Return the profile data as JS objects
: Return the profile data as JS objects
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Gecko Profiler (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla13
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-02 14:07 PST by Jeff Muizelaar [:jrmuizel]
Modified: 2012-03-10 02:51 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Return JSObjects (10.28 KB, patch)
2012-02-03 08:25 PST, Jeff Muizelaar [:jrmuizel]
bgirard: review+
Details | Diff | Review

Description Jeff Muizelaar [:jrmuizel] 2012-02-02 14:07:59 PST
This will be nicer to use and easier to extend.
Comment 1 Jeff Muizelaar [:jrmuizel] 2012-02-03 08:25:47 PST
Created attachment 594193 [details] [diff] [review]
Return JSObjects
Comment 2 Benoit Girard (:BenWa) 2012-02-10 15:02:52 PST
Comment on attachment 594193 [details] [diff] [review]
Return JSObjects

Review of attachment 594193 [details] [diff] [review]:
-----------------------------------------------------------------

r+ based on us later moving JSBuilder.h

::: tools/profiler/sps/JSBuilder.h
@@ +40,5 @@
> +/* this is handy wrapper around JSAPI to make it more pleasant to use.
> + * We collect the JSAPI errors and so that callers don't need to */
> +class JSObjectBuilder
> +{
> +  public:

Typically these are left aligned.

@@ +141,5 @@
> +  JSObjectBuilder(JSContext *aCx) : mCx(aCx), mOk(JS_TRUE)
> +  {
> +  }
> +  private:
> +  JSObjectBuilder(JSObjectBuilder&);

You're not disallowing the evil assignment operator.
Comment 3 Marco Bonardo [::mak] 2012-03-10 02:48:04 PST
https://hg.mozilla.org/mozilla-central/rev/c433e993506b
Comment 4 Marco Bonardo [::mak] 2012-03-10 02:49:41 PST
hm, looks like this has been backed out but not annotated

Note You need to log in before you can comment on or make changes to this bug.