The default bug view has changed. See this FAQ.

regression: XUL Fennec uses non-tablet layout on ICS tablets

RESOLVED FIXED in Firefox 13

Status

Fennec Graveyard
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

({regression})

Firefox 13
Firefox 13
All
Android
regression

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 593993 [details] [diff] [review]
patch

Regression from bug 671634, which changed an nsSystemInfo property from "isTablet" to "tablet" without updating the existing code that used the property.
Attachment #593993 - Flags: review?(mark.finkle)
Attachment #593993 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 1

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/eddcf32f7b6f
Whiteboard: [has patch]
Target Milestone: --- → Firefox 13
(Assignee)

Comment 2

5 years ago
Comment on attachment 593993 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): bug 671634

User impact if declined: Firefox uses non-tablet on tablets running Android 4.

Testing completed (on m-c, etc.): Landed on inbound Februrary 2.

Risk to taking this patch (and alternatives if risky):  Extremely low risk. Trivial (one-line) XUL-fennec-only patch to fix an obvious regression.

String changes made by this patch: None.

Note: This patch should land on Aurora/Beta at the same time as bug 671634.
Attachment #593993 - Flags: approval-mozilla-beta?
Attachment #593993 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/eddcf32f7b6f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 4

5 years ago
Comment on attachment 593993 [details] [diff] [review]
patch

[Triage Comment]
Approved for Aurora 12 and Beta 11.
Attachment #593993 - Flags: approval-mozilla-beta?
Attachment #593993 - Flags: approval-mozilla-beta+
Attachment #593993 - Flags: approval-mozilla-aurora?
Attachment #593993 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-beta/rev/75af2e2b2238
status-firefox11: --- → fixed
https://hg.mozilla.org/releases/mozilla-aurora/rev/c7f3d449b282
tracking-fennec: ? → 11+
status-firefox12: --- → fixed
status-firefox13: --- → fixed
(Assignee)

Comment 7

5 years ago
Comment on attachment 593993 [details] [diff] [review]
patch

Requesting approval-mozilla-esr10 because this patch blocks bug 671634.  See bug 671634 comment 94 for details.
Attachment #593993 - Flags: approval-mozilla-esr10?
status-firefox-esr10: --- → affected
tracking-firefox-esr10: --- → 12+
Comment on attachment 593993 [details] [diff] [review]
patch

[Triage Comment]
Android-only, low risk
Attachment #593993 - Flags: approval-mozilla-esr10? → approval-mozilla-esr10+
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/releases/mozilla-esr10/rev/b2536595389a
status-firefox-esr10: affected → fixed

Comment 10

5 years ago
Tablet layout display on Asus Eee Transformers (Android 4.0.3) on build: Mozilla/5.0 (Android; Tablet; rv:10.0.4esrpre) Gecko/10.0.4es Firefox/10.0.4esrpre Fennec/10.0.4esrpre
status-firefox-esr10: fixed → verified
You need to log in before you can comment on or make changes to this bug.