Malicious "Prenium plugin" add-on

RESOLVED FIXED

Status

()

Toolkit
Blocklisting
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: MarkH, Assigned: jorgev)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

30.87 KB, application/octet-stream
Details
(Reporter)

Description

7 years ago
Created attachment 594043 [details]
20120203 gaze98cent.zip

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_2) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7

Steps to reproduce:

Downloaded and installed buyhatnews.info/video/prenium.xpi


Actual results:

Injects youtube.js ->
http://gaze98cent.info/s.js ->
http://gaze98cent.info/e.js

e.js injects http://gaze98cent.info/verify.php and
http://gaze98cent.info/f2/f.js

f.js:

Has these blog URLs:
blogs[0] = 'http://doabtzd548se.blogspot.com/?';
blogs[1] = 'http://wwtahclspdols.blogspot.com/?';

Steals your cookies on Facebook

Spams " HOLY W0W HAVE YOU VIEWED THIS? " and mentions your friends on the post to /ajax/connect/external_edge_comment.php

Injects http://slmanjdoso.altervista.org/kim2.php

kim2.php:

steals your cookies

Has you like this FB page ID: "289465087780323" via /ajax/pages/fan_status.php

Posts the spam of var msgww = "Girl killed herself because of her dad ... watch all the story";
var uri = "http://bit.ly/wTUZ70";
to /ajax/updatestatus.php and /ajax/ufi/modify.php


Expected results:

It should not steal your cookies and post messages to Facebook without your consent.
(Assignee)

Comment 1

7 years ago
<em:id>youtube@youtube3.com</em:id>
Assignee: nobody → jorge
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 2

7 years ago
https://addons.mozilla.org/en-US/firefox/blocked/i60
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Duplicate of this bug: 728108
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.