Firefox 10.0 Crash @ nsRefPtr<nsIDOMEventListener>

RESOLVED DUPLICATE of bug 722039

Status

()

Core
Spelling checker
--
critical
RESOLVED DUPLICATE of bug 722039
7 years ago
7 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

Trunk
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Seen while looking at 10 crash stats. New signature to 10. https://crash-stats.mozilla.com/report/list?signature=nsRefPtr%3CnsIDOMEventListener%3E::~nsRefPtr%3CnsIDOMEventListener%3E%28%29%20|%20nsCOMPtr%3CnsIRDFNode%3E::%60scalar%20deleting%20destructor%27%27%28unsigned%20int%29%20|%20nsTArrayElementTraits%3CnsCOMPtr%3CnsIDOMBlob%3E%20%3E::Destruct%28nsCOMPtr%3CnsIDOMBlob%3E*%29 indicates crashes are all Windows so far.

One comment says: "Seems to crash on the Spell Check feature of IBM Lotus Notes Web-mail, when it "pops" up the spell-check dialog"

Please feel free to change the component as I was not sure where it belongs.

https://crash-stats.mozilla.com/report/index/8c63f0cd-575a-439c-b2fe-057992120202

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsRefPtr<nsIDOMEventListener>::~nsRefPtr<nsIDOMEventListener> 	obj-firefox/xpcom/build/nsCOMPtr.cpp:81
1 	xul.dll 	nsCOMPtr<nsIRDFNode>::`scalar deleting destructor' 	
2 	xul.dll 	nsTArrayElementTraits<nsCOMPtr<nsIDOMBlob> >::Destruct 	obj-firefox/dist/include/nsTArray.h:359
3 	xul.dll 	nsTArray<RangeData,nsTArrayDefaultAllocator>::DestructRange 	obj-firefox/dist/include/nsTArray.h:1202
4 	xul.dll 	nsTArray<RangeData,nsTArrayDefaultAllocator>::RemoveElementsAt 	obj-firefox/dist/include/nsTArray.h:932
5 	xul.dll 	nsTypedSelection::AddItem 	
6 	xul.dll 	nsTypedSelection::addTableCellRange 	layout/generic/nsSelection.cpp:3159
7 	xul.dll 	nsTypedSelection::AddRange 	layout/generic/nsSelection.cpp:4773
8 	xul.dll 	nsTypedSelection::AddRange 	layout/generic/nsSelection.cpp:4756
9 	xul.dll 	mozInlineSpellChecker::AddRange 	extensions/spellcheck/src/mozInlineSpellChecker.cpp:1629
10 	xul.dll 	mozInlineSpellChecker::DoSpellCheck 	extensions/spellcheck/src/mozInlineSpellChecker.cpp:1427

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Component: Layout: Text → Spelling checker
QA Contact: layout.fonts-and-text → spelling-checker
Resolution: --- → DUPLICATE
Duplicate of bug: 722039
You need to log in before you can comment on or make changes to this bug.