Outliner: Expanding/Collapsing a thread messes up the currently selected item

VERIFIED DUPLICATE of bug 72256

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 72256
18 years ago
14 years ago

People

(Reporter: Håkan Waara, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: perf)

(Reporter)

Description

18 years ago
This is what I experience daily while surfing the newsgroups:

Reproduce it like this:

1. Go to a newsgroup which has some thread
2. Select an item below the main thread row with a "+". The thread may be
collapsed or expanded.
3. Now toggle the "+"/"-", so click on it while having the item under it selected.

Example:

If you have a thread, initally collapsed like this:

+  Blah
   Other message
   Another message

then select the "Other Message": ("//" is for the selected item)

+ Blah
  //Other message//
  Another message

now, expand the thread:

- Blah
  -- //Re:Blah//
  Other message
  Another message


Other message should be selected; the currently selected row should change when
you expand/collapse a thread.

It was hard to explain this, I hope you all understand now. :)

I would figure this is the case for *all* threads throughout the app, so this
may also appear in the message pane for POP/IMAP and such.
(Reporter)

Updated

18 years ago
Blocks: 72338
(Reporter)

Comment 1

18 years ago
nominating for nsbeta1 and mozilla0.9
No longer blocks: 72338
Keywords: mozilla0.9, nsbeta1
Whiteboard: perf

Comment 2

18 years ago
I think this is a dup of 72256.

*** This bug has been marked as a duplicate of 72256 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

18 years ago
Yep. Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.