java.lang.NullPointerException at org.mozilla.gecko.GeckoApp.handleMessage(GeckoApp.java:908) when disabling Full Screen add-on

VERIFIED FIXED in Firefox 11

Status

()

defect
--
critical
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: xti, Assigned: mbrubeck)

Tracking

({crash, regression, reproducible})

Trunk
Firefox 13
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox11 verified, firefox12 verified, firefox13 verified)

Details

(Whiteboard: [native-crash])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Mozilla/5.0 (Android;Linux armv7l;rv:13.0a1)Gecko/20120203
Firefox/13.0a1 Fennec/13.0a1
Device: HTC Desire
OS: Android 2.2

Steps to reproduce:
1. Open Fennec
2. Go to addons.mozilla.org/en-US/android/
3. Install Full Screen add-on
4. Go to Add-ons Manager
5. Disable Full Screen Add-on

Expected result:
After step 5, Full screen add-on is visibly disabled. No errors should occur.

Actual result:
After step 5, Fennec is still in full screen mode. Also the following errors occur in logcat:

    I/GeckoApp(10588): Got message: Menu:Remove
    E/GeckoApp(10588): Exception handling message "Menu:Remove":
    E/GeckoApp(10588): java.lang.NullPointerException
    E/GeckoApp(10588):      at org.mozilla.gecko.GeckoApp.handleMessage(GeckoApp.java:908)
    E/GeckoApp(10588):      at org.mozilla.gecko.GeckoAppShell.handleGeckoMessage(GeckoAppShell.java:1676)
    E/GeckoApp(10588):      at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
    E/GeckoApp(10588):      at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
    E/GeckoApp(10588):      at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:495)
    E/GeckoApp(10588):      at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:104)
    E/GeckoConsole(10588): [JavaScript Warning: "Duplicate resource declaration for 'gre-resources' ignored." {file: "jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/omni.ja!/chrome/nonlocalized.manifest" line: 11}]
    E/GeckoConsole(10588): Could not read chrome manifest 'file:///data/data/org.mozilla.fennec/chrome.manifest'.
Severity: normal → critical
Whiteboard: [native-crash]
(Assignee)

Updated

7 years ago
Assignee: nobody → mbrubeck

Updated

7 years ago
Summary: java.lang.NullPointerException when disabling Full Screen add-on → java.lang.NullPointerException at org.mozilla.gecko.GeckoApp.handleMessage(GeckoApp.java:908) when disabling Full Screen add-on
(Reporter)

Updated

7 years ago
(Assignee)

Comment 1

7 years ago
Posted patch patchSplinter Review
This fixes the NullPointerException.  I think the exception happened only if you have never pressed the Menu key since Fennec was launched.

There's still a separate bug that Fennec does not exit full-screen mode when the add-on is disabled.
Attachment #594256 - Flags: review?(sriram)
Comment on attachment 594256 [details] [diff] [review]
patch

This looks good to me.
Attachment #594256 - Flags: review?(sriram) → review+
https://hg.mozilla.org/mozilla-central/rev/766a59650976
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Comment on attachment 594256 [details] [diff] [review]
patch

[Approval Request Comment]
User impact if declined: Crash when enabling/disabling add-ons
Testing completed (on m-c, etc.): Needs to be verified
Risk to taking this patch (and alternatives if risky): Low
Attachment #594256 - Flags: approval-mozilla-beta?
Attachment #594256 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 5

7 years ago
(In reply to Matt Brubeck (:mbrubeck) from comment #1)
> There's still a separate bug that Fennec does not exit full-screen mode when
> the add-on is disabled.

This was a bug in the add-on itself; see bug 723977.

Updated

7 years ago
Target Milestone: --- → Firefox 13
Comment on attachment 594256 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Attachment #594256 - Flags: approval-mozilla-beta?
Attachment #594256 - Flags: approval-mozilla-beta+
Attachment #594256 - Flags: approval-mozilla-aurora?
Attachment #594256 - Flags: approval-mozilla-aurora+
(Reporter)

Comment 7

7 years ago
Verified fixed on:

Firefox 13.0a1 (2012-02-05)
20120205031129
http://hg.mozilla.org/mozilla-central/rev/ccbb41b873cd
Device: HTC Desire
OS: Android 2.2
Not yet landed in Fx 11 and 12.
(Reporter)

Comment 11

7 years ago
Verified fixed on:

Firefox 12.0a2 (2012-02-07)
20120207042017
http://hg.mozilla.org/releases/mozilla-aurora/rev/cd3f31d128b8
Device: HTC Desire Z
OS: Android 2.3.3

Firefox 11.0
20120206202409
http://hg.mozilla.org/releases/mozilla-beta/rev/1c0aba74d116
Device: HTC Desire Z
OS: Android 2.3.3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.