Closed Bug 723947 Opened 10 years ago Closed 9 years ago

Text size is reset (made smaller again) after di.se completes loading

Categories

(Tech Evangelism Graveyard :: Swedish, defect, P5)

x86_64
Windows 7
defect

Tracking

(blocking-fennec1.0 -)

RESOLVED WORKSFORME
Tracking Status
blocking-fennec1.0 --- -

People

(Reporter: djst, Unassigned)

References

Details

(Whiteboard: readability,)

Steps to reproduce: 
1. Navigate to http://di.se
2. Notice how the text of the main content is conveniently enlarged while the page is loading.
3. Wait for the page to finish loading. Now notice how the text became small again.

di.se is one of the most visited finance/industrial news site in Sweden. 

Tested in Fennec Nightly (13.0a1 2012-02-03) and Aurora (11.0a2 2012-01-31).
Whiteboard: readability,
Priority: -- → P1
Release blockers.
blocking-fennec1.0: --- → +
So this is explicitly setting a height on two of the divs somewhat inside the structure of the page to an explicit pixel value.  So similar to bug 711418, but different.  At least that's the obvious reason I see that things wouldn't be inflated.

I tend to think we probably shouldn't block on this one.
On what basis do you believe we shouldn't block -- poor website HTML/CSS? 

It's the #1 most visited finance website (#29 most visited site overall) in Sweden.
(In reply to David Tenser [:djst] from comment #3)
> On what basis do you believe we shouldn't block -- poor website HTML/CSS? 

Yes.  The site is explicitly setting a fixed height on a div nested a bit inside its content when the page finishes loading.  We disable inflation inside elements with a fixed height because inflation is likely to cause such elements to overflow.
While I obviously agree about the poor coding on this site (there are so many things I don't like about its design which hurts readability), it would be good to think about what we can do to ensure sites like this remain readable in Firefox to stay ahead of the mobile web browser competition... this bug being a blocker or not.
Resetting the blocking-fennec1.0 flag from + to ? (with the suggestion that it be changed to -) because I think this bug isn't something we should try to fix.  The Web page is doing something particularly strange that triggers one of our more important heuristics for when we need to avoid font inflation -- it's setting element.style.height after the page finishes loading, and we intentionally don't inflate in pages that have a fixed height because that's a case where there would be likely to be overlap.
blocking-fennec1.0: + → ?
agreed
blocking-fennec1.0: ? → -
I don't think there's anything reasonable we can do here from a Layout perspective, so moving to evang.
Assignee: nobody → swedish
Component: General → Swedish
Product: Fennec Native → Tech Evangelism
QA Contact: general → swedish
Version: Trunk → unspecified
P5 per font inflation scrub.
Priority: P1 → P5
Can't reproduce this any more using the STR in comment 0. The page seems to render fine now; tested on a Galaxy Nexus with the 27 nov nightly using text sizes medium and extra large.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.