[NativeUI GA] Implement /fx update

RESOLVED FIXED in Future

Status

www.mozilla.org
General
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Jaclyn Fu, Assigned: sgarrity)

Tracking

unspecified
Future
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Due 8/7, URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Hi,

Placeholder to implement and replace the current tablet promo on /fx with an updated Native UI phone promo.

Would like to localize this promo in ko, de, fr, es, ru, ja (Kohei - do people from Japan see this promo or are they redirected to moz.jp?) 

Laura/Chrissie - please update us with the timeline when you know

Thanks!
(Reporter)

Updated

6 years ago
Depends on: 724083
(Reporter)

Comment 1

6 years ago
Update: 

Design hand-off is March 14
(Reporter)

Comment 2

6 years ago
Hi all - update that the final release launch for native UI won't go out until sometime around early June (roughly following timeline of FF13). 

Thanks everyone
Summary: [Mobile] Implement /fx update for FF11 → [NativeUI GA] Implement /fx promo update
(Reporter)

Comment 3

6 years ago
Kohei - do visitors in Japan see this page? http://www.mozilla.org/firefox/fx/
(Reporter)

Updated

6 years ago
Depends on: 740132
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Here's the PSD:
http://cl.ly/3J3t2p3G091z3E2u3Y0H

Go live date is 6/26.
Assignee: nobody → steven
(Reporter)

Comment 5

6 years ago
Hi Mike,

Can we scope this for a Aug 6 or 7 live date?

Thanks
(In reply to Jaclyn Fu from comment #5)

> Can we scope this for a Aug 6 or 7 live date?

Yes. 

Steven, so just to clarify, this promo isn't tied to the NativeUI GA. They want the campaign to be pushed out in phases.
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: Due 8/7
Target Milestone: --- → Future
(Reporter)

Comment 7

5 years ago
This page has been re-scoped as the download page for desktop and for mobile. We'll need this page live for June 26

Thank you!

Updated

5 years ago
Duplicate of this bug: 763648

Comment 9

5 years ago
Removing the word 'promo' from the description, b/c as Jaclyn notes this has evolved into something more comprehensive.
Summary: [NativeUI GA] Implement /fx promo update → [NativeUI GA] Implement /fx update

Comment 10

5 years ago
PSD here:
http://cl.ly/3d3x140J0e2A2Y0D221c
Blocks: 766214
On stage at http://www-dev.allizom.org/en-US/firefox/fx/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(In reply to Craig Cook (:craigcook) from comment #11)
> On stage at http://www-dev.allizom.org/en-US/firefox/fx/

(or soon will be, rather... stage should autoupdate from git in a few minutes.)

Updated

5 years ago
Depends on: 766785

Comment 13

5 years ago
Thanks Craig. One quick note - the "learn more about Firefox for Android" link on #mobile should point to the features page rather than /mobile.
(Reporter)

Comment 14

5 years ago
for #mobile, systems and languages should be "Supported Devices" that point to mozilla.org/mobile/platforms

What's New should link to mozilla.org/mobile/notes

Learn more about firefox for Android should link to mozilla.org/mobile/features

Thanks
Created attachment 635526 [details]
Shows Andriod download button on IPhone

The Android download button is shown to iphone users
http://cl.ly/2d0q0Q060m3R1f3M0z2y
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The mobile page is shown first when you visit 
http://www-dev.allizom.org/en-US/firefox/fx/
 in Opera  12.00

http://cl.ly/07082g1e133n3U1p3v1h
(Assignee)

Comment 18

5 years ago
(In reply to raymond [:retornam] from comment #15)
> The Android download button is shown to iphone users

I think this is the intended behaviour. We don't have a download option for iPhone users, and they won't be directly to this page (they'll be sent to .org/mobile).

(In reply to raymond [:retornam] from comment #17)
> The mobile page is shown first when you visit 
> http://www-dev.allizom.org/en-US/firefox/fx/
>  in Opera  12.00

This is also the intended behaviour. At launch, all visitors to this page will default to the mobile tab. If an opera visitor goes to mozilla.org/firefox, they'll be redirect to the /new page instead of this page.
(In reply to Steven Garrity from comment #18)
> (In reply to raymond [:retornam] from comment #15)
> > The Android download button is shown to iphone users
> 
> I think this is the intended behaviour. We don't have a download option for
> iPhone users, and they won't be directly to this page (they'll be sent to
> .org/mobile).
> 
> (In reply to raymond [:retornam] from comment #17)
> > The mobile page is shown first when you visit 
> > http://www-dev.allizom.org/en-US/firefox/fx/
> >  in Opera  12.00
> 
> This is also the intended behaviour. At launch, all visitors to this page
> will default to the mobile tab. If an opera visitor goes to
> mozilla.org/firefox, they'll be redirect to the /new page instead of this
> page.

Steven we are re-creating the problem we had earlier.Firefox users who visit this page should see the intended behaviour but other browsers should be redirected to /new the moment they hit /fx . If I am an Opera user on desktop and I end up on this page I should see the link to download Firefox immediately and not have to click through to switch to the Firefox download page.


Also ios users should be redirected to the /ios page weh they end up on /fx
On #desktop, the kerning on the headline is really tight (the exclamation mark touches the Y in "Hooray" and the F and I in Firefox bleed together).

Also on #desktop, the line "You've come to the right place!" in the first promo looks really tight to the download button.

On #mobile, the F in "for Android" on the download button should be lowercase.

Also on #mobile, is the HTML5 logo correct on the third promo? It's a link to the Google Play Store.
(Assignee)

Comment 21

5 years ago
(In reply to John Slater from comment #13)
> Thanks Craig. One quick note - the "learn more about Firefox for Android"
> link on #mobile should point to the features page rather than /mobile.

Done.

(In reply to Jaclyn Fu from comment #14)
> for #mobile, systems and languages should be "Supported Devices" that point
> to mozilla.org/mobile/platforms, What's New should link to mozilla.org/mobile/notes
> Learn more about firefox for Android should link to
> mozilla.org/mobile/features

Done.

Matej's feedback from comment #20 has been addressed too (thanks Matej).
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Hi, I think the Mobile and Desktop tabs should be reversed (left: Desktop, right: Mobile) because the header navigation is lined with Desktop, Mobile, Releases... It lacks consistency in the order.
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.