Last Comment Bug 724080 - Broken link to Mozilla Manifesto on about:mozilla page in Firefox
: Broken link to Mozilla Manifesto on about:mozilla page in Firefox
Status: RESOLVED FIXED
[good first bug][mentor=felipe]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 13
Assigned To: lmanuelab
:
Mentors:
Depends on: 735404
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-03 12:58 PST by Terry R.
Modified: 2012-06-15 15:37 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
about:mozilla (1.37 KB, patch)
2012-02-23 12:00 PST, lmanuelab
felipc: feedback+
Details | Diff | Review
aboutMozillaPatch2 (1.83 KB, patch)
2012-02-23 22:38 PST, lmanuelab
felipc: review+
Details | Diff | Review

Description Terry R. 2012-02-03 12:58:21 PST
In Firefox, type about:mozilla in address bar.
"sacred words" links to http://www.mozilla.org/about/mozilla-manifesto.html and is 404.  http://www.mozilla.org/about/manifesto.html works.
Comment 1 David Boswell 2012-02-03 13:09:02 PST
Thanks for reporting.  Fixed in r101093.
Comment 2 David Boswell 2012-02-03 13:59:25 PST
Reopening.  I realize that the mozilla.org/book page is not that page that is being called up by about:mozilla in Firefox.  That must be a legacy page that is not in use now.

This should be reassigned to the Firefox product where someone will know how to update the link in that page.
Comment 4 Justin Dolske [:Dolske] 2012-02-03 18:07:22 PST
Also see http://mxr.mozilla.org/mozilla-central/source/toolkit/content/mozilla.xhtml

Current preference is to not localize links, but handle that serverside.

The fix here should be to:

* Split up &mozilla.quote; into multiple chunks
* Change mozilla.xhtml to include <a href="..."> and use the multiple chunks

Eg

&foo1;<a href="bar.html">&foo2;</a>&foo3;<a href="baz.html">&foo4;</a>&foo5;

The chunks are needed to locales can split text as needed, some chunks may even be empty.
Comment 5 :Felipe Gomes (needinfo me!) 2012-02-22 16:47:35 PST
Guacamole, what "needs" to be fixed here is the URL only, but what Dolske is suggesting is that while we are at it we should split that long text into multiple segments because that's how this is usually done, and it makes it easier to maintain in the future.

See an example here: http://mxr.mozilla.org/mozilla-central/source/testing/extensions/community/chrome/content/tabs/chat.xul#71
Think about how the whole content inside the <li> could have been a single entity, however there are 2 "&..." (entities) there because they are the logical units here.

So what you need to do is to split the text in the dtd into various parts:
"part before the url", "the url", "the url name", "part of the url"..

and then also change mozilla.xhtml to use all these entities, instead of just &mozilla.quote as it does now
Comment 6 lmanuelab 2012-02-23 12:00:14 PST
Created attachment 600123 [details] [diff] [review]
about:mozilla
Comment 7 :Felipe Gomes (needinfo me!) 2012-02-23 16:26:20 PST
Comment on attachment 600123 [details] [diff] [review]
about:mozilla

This is looking good, thanks for the patch! There's still a few changes that we should do before reviewing:

- Whenever we change a string, due to the way the localization process works, we need to change its name too. You can just add a 2, changing mozilla.quote to mozilla.quote2.

- You can keep the markup and the text (sacred words/spoke) inside the same quote. Let's just move the actual URLs to new entities and then reference them inside the <a href="...">

- Please declare the URL entities before the quote (just for clarity)
Comment 8 Bill Gianopoulos [:WG9s] 2012-02-23 17:40:33 PST
OK now really.  No matter what is done here to fix this long term and correctly, the links in the release version will still be broken.  I doubt there is going to be a 10.0.3 to fix this.  I also bet it is to far into the beta cycle to get a fix here into version 11.  The obvious short term thing to do is to make do a server-side change to make the link in the current release Firefox just work.

I would really wish the people resisting doing this would explain their reasoning for their position.
Comment 9 lmanuelab 2012-02-23 22:38:43 PST
Created attachment 600313 [details] [diff] [review]
aboutMozillaPatch2
Comment 10 :Felipe Gomes (needinfo me!) 2012-02-24 12:56:39 PST
Comment on attachment 600313 [details] [diff] [review]
aboutMozillaPatch2

Looks perfect, thanks!

We should also file a bug to get the URL on the server-side to do proper locale redirection, and see if this is the final URL that Webdev wants to have the manifesto hosted.

WG9s: mozilla.org went through some big changes recently and even if we get a server-side redirect to fix this for the current releases (can you file a bug on that?), it's better to have the product pointing to the correct new URI.
Comment 11 :Felipe Gomes (needinfo me!) 2012-02-27 18:14:19 PST
Pushed to inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/11af9adc0e5d
Comment 12 Matt Brubeck (:mbrubeck) 2012-02-28 09:57:05 PST
Fixed in mozilla-central for Firefox 13.  This fix should be included in tomorrow's Nightly build.  Thanks!
https://hg.mozilla.org/mozilla-central/rev/11af9adc0e5d
Comment 13 Daniel Cater 2012-03-13 12:30:57 PDT
This was backed out but not mentioned so here is the changeset: https://hg.mozilla.org/mozilla-central/rev/825a808d224f
Comment 14 :Felipe Gomes (needinfo me!) 2012-06-15 15:37:05 PDT
Fixed by Bug 735404

Note You need to log in before you can comment on or make changes to this bug.