Closed Bug 724111 Opened 10 years ago Closed 9 years ago

After page fires an ajax request view source displays the ajax request's response

Categories

(Firefox :: Untriaged, defect)

13 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: baileylo, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0a1) Gecko/20120203 Firefox/13.0a1
Build ID: 20120203031138

Steps to reproduce:

Fire ajax request on page and then view page source, either by right clicking and selecting "View Page Source" or using command u.


Actual results:

The text in the Source window was the ajax request's response.


Expected results:

The window should've shown the source of the page.
I was also able to reproduce this in Version: 12 Branch
Please provide a public URL or reduced test case that exhibits this issue.
Attached file Movie of the issue
This is a video of it happening!
Hi Logan, it's been a while since anyone addressed this bug report. Are you still seeing the problem? 

The idea behind asking for a reduced test case is for someone else to be able to directly experience the bug.  

Thanks!
Flags: needinfo?(logan)
Hi Liz, I just checked and I'm no longer seen this issue in the current version of Firefox.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Flags: needinfo?(logan)
Resolution: --- → WORKSFORME
I can reproduce this bug on last version (36.0.1)

http://test-bug.f-y.name/

It is here if I request with AJAX the same exact URL as current page (and send different info, e.g. by checking request.is_ajax https://docs.djangoproject.com/en/1.7/ref/request-response/#django.http.HttpRequest.is_ajax )
You need to log in before you can comment on or make changes to this bug.