on the linux platform, native firefox context menus appear onmousedown instead of onmouseup.

RESOLVED DUPLICATE of bug 1360278

Status

()

Firefox
Extension Compatibility
RESOLVED DUPLICATE of bug 1360278
6 years ago
3 months ago

People

(Reporter: bugzilla-fromthedeep, Unassigned)

Tracking

10 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

Steps to reproduce:

1. In any linux distro, download and install firefox from mozilla.com

2. Install a handful of addons which add things to the context menu

3. Browse the web over a prolonged period and occasionally right-click to open a link in a new tab.



Actual results:

The instant I tap the right click button on my mouse, a context menu appears where I clicked, and a random context menu item is instantly selected. Then, any of a number of random things might happen, depending on which item got selected.


Expected results:

A context menu should have appeared only onmouseup, instead of onmousedown, so that I don't inadvertently select a context menu item. Note, this (context menu onmouseup) is the default behavior on Windows.
Mozilla/5.0 (X11; Linux x86_64; rv:13.0a1) Gecko/20120205 Firefox/13.0a1

So, as I understand this, this is an add-on issue. 
Could you figure out which add-on triggered this issue by enabling add-ons one at a time until the one that caused this is found?

https://support.mozilla.com/en-US/kb/Safe+Mode
Component: Untriaged → Extension Compatibility
QA Contact: untriaged → extension.compatibility
(Reporter)

Comment 2

6 years ago
Actually, I suspect this has more to do with the way the menu is handled; the specific addon that gets triggered depends more on where the mouse ends up in the menu, and is therefore somewhat random. The other factor I suspect comes into play is screen size. My screen is 1024x768.

My addon assortment has changed quite a bit since I filed this bug, and I have removed many addons; Sorry I didn't reply sooner. I disabled addons until I could no longer reproduce the problem, this required disabling one addon, which had added one entry to the menu. The total length of my menu is about 100 pixels longer than default; with the one removed element, it was only about 75 pixels longer than default.

Updated

3 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1360278
You need to log in before you can comment on or make changes to this bug.