Intermittent browser_477657.js | an unexpected uncaught JS exception reported through window.onerror - Script error. at chrome://browser/content/aboutSessionRestore.js:0

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

Trunk
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Haven't looked, but this really should have a recent sharp edge where it started - I've been seeing it all day, waiting for someone to file it, and I'm pretty sure today is the first day of that wait (unless it actually started ignored on fx-team).

https://tbpl.mozilla.org/php/getParsedLog.php?id=9079393&tree=Mozilla-Inbound
Rev3 Fedora 12x64 mozilla-inbound opt test mochitest-other on 2012-02-03 17:19:34 PST for push 948fe2e7f1d5

TEST-INFO | checking window state
TEST-START | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_477657.js
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_477657.js | window value was set before the window was overwritten
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_477657.js | window value was implicitly cleared
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_477657.js | the window was maximized
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_477657.js | the closed tab was added before the window was overwritten
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_477657.js | closed tabs were implicitly cleared
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_477657.js | the window remains maximized
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_477657.js | the window was explicitly unmaximized
INFO TEST-END | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_477657.js | finished in 252ms
TEST-INFO | checking window state
TEST-INFO | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_477657.js | must wait for focus
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_477657.js | an unexpected uncaught JS exception reported through window.onerror - Script error. at chrome://browser/content/aboutSessionRestore.js:0
Stack trace:
    JS frame :: chrome://mochikit/content/tests/SimpleTest/SimpleTest.js :: simpletestOnerror :: line 968
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_477657.js | an unexpected uncaught JS exception reported through window.onerror - Script error. at chrome://browser/content/aboutSessionRestore.js:0
Stack trace:
    JS frame :: chrome://mochikit/content/tests/SimpleTest/SimpleTest.js :: simpletestOnerror :: line 968
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_477657.js | an unexpected uncaught JS exception reported through window.onerror - Script error. at chrome://browser/content/aboutSessionRestore.js:0
Stack trace:
    JS frame :: chrome://mochikit/content/tests/SimpleTest/SimpleTest.js :: simpletestOnerror :: line 968
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_477657.js | an unexpected uncaught JS exception reported through window.onerror - Script error. at chrome://browser/content/aboutSessionRestore.js:0
Stack trace:
    JS frame :: chrome://mochikit/content/tests/SimpleTest/SimpleTest.js :: simpletestOnerror :: line 968
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
I think something is causing these errors to just take longer to bubble up maybe? Bug 722728 came up recently and it's the same thing. about:sessionrestore isn't actually loaded in either of these tests but there are previous tests that it is. Time to fix the root cause I think.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.