Last Comment Bug 724217 - New Tab page should be user skinnable
: New Tab page should be user skinnable
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: unspecified
: x86 Windows 7
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 455553 729878
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-04 01:09 PST by patrickjdempsey
Modified: 2012-03-16 01:12 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description patrickjdempsey 2012-02-04 01:09:27 PST
A very common request users have for Firefox customization is the ability to display either a dark color or an image on a blank tab.  The current (ancient) method for doing this is to skin about:blank, which causes iframes on websites to break.  With the New Tab page, there is now at least the potential to fix this long-standing user-request.  

Is there a possibility of adding a custom class to the background #scrollbox element so that userStyles could easily target it for styling?
Comment 1 mcdavis941 (sporadically reading bugmail) 2012-02-04 15:43:04 PST
(In reply to patrickjdempsey from comment #0)
> With the New Tab page, there is now at least the
> potential to fix this long-standing user-request.
> Is there a possibility of adding a custom class

Yes, please.  What Patrick said.

> to the background #scrollbox element so that userStyles could 
> easily target it for styling?

(Or to the root element of the document embodying about:newtab, so that absolutely everything in it is targetable, including anything that might be added by an add-on.)
Comment 2 patrickjdempsey 2012-03-16 01:09:54 PDT
I'm going to mark this one Resolved as a Duplicate:
https://bugzilla.mozilla.org/show_bug.cgi?id=729878

The new design uses #newtab-window as the root xul:window so anything added by an extension should be included.  Major win for the Users!

*** This bug has been marked as a duplicate of bug 729878 ***
Comment 3 Tim Taubert [:ttaubert] 2012-03-16 01:12:32 PDT
Let's rather say this has been fixed by bug 729878. Anyway, good to see it's now skinnable.

Note You need to log in before you can comment on or make changes to this bug.