CSS ::-moz-selection { text-shadow: } is ignored

RESOLVED DUPLICATE of bug 721750

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 721750
6 years ago
6 years ago

People

(Reporter: Cacycle, Unassigned)

Tracking

10 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 594435 [details]
testcase selection text-shadow.html

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

For CSS styling,   text-shadow is ignored for ::-moz-selection. Therefore, it is no longer possible to turn of shading in selections. Example code:

	BODY {
	  text-shadow: red -1px -1px 0;
	}

	::-moz-selection {
	  text-shadow: none; /* this will be ignored */
	  color: green;
	  background: cyan;
	}



Actual results:

Color and background styling is applied to selections, but not text shadow. The text stays shadowed in selections, rendering the selected text unreadable in many cases.


Expected results:

Text shadow should work in selections and it did in pre-10.0 as far as I remember

Updated

6 years ago
Component: Untriaged → Style System (CSS)
Product: Firefox → Core
QA Contact: untriaged → style-system

Updated

6 years ago
Attachment #594435 - Attachment mime type: text/plain → text/html

Comment 1

6 years ago
Created attachment 594437 [details]
big shadow

Comment 2

6 years ago
I think this is not a regression. this is side effect of Bug 692752.

the text-selection highlight is painted on top of any text-shadow:
http://hg.mozilla.org/mozilla-central/rev/b4da2d439cbc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111009 Firefox/10.0a1 ID:20111009031012
the text-selection highlight is not painted on top of any text-shadow:
http://hg.mozilla.org/mozilla-central/rev/36cadf889624
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111009 Firefox/10.0a1 ID:20111009072055
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b4da2d439cbc&tochange=36cadf889624

the text-selection highlight is painted on top of any text-shadow:
http://hg.mozilla.org/integration/mozilla-inbound/rev/be16a71b5ab4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111007 Firefox/10.0a1 ID:20111008014456
the text-selection highlight is not painted on top of any text-shadow:
http://hg.mozilla.org/integration/mozilla-inbound/rev/fbe700c7747c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111007 Firefox/10.0a1 ID:20111008113756
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=be16a71b5ab4&tochange=fbe700c7747c

Comment 3

6 years ago
I reopened bug 721750 for this issue
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 721750
You need to log in before you can comment on or make changes to this bug.