Last Comment Bug 724256 - Optimize move file calls on Windows, saving about 2ms per call (1 call on startup)
: Optimize move file calls on Windows, saving about 2ms per call (1 call on sta...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla13
Assigned To: Brian R. Bondy [:bbondy]
:
: Nathan Froyd [:froydnj]
Mentors:
Depends on: 375778
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-04 07:35 PST by Brian R. Bondy [:bbondy]
Modified: 2012-02-07 15:05 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1. (1.12 KB, patch)
2012-02-04 07:35 PST, Brian R. Bondy [:bbondy]
benjamin: review+
Details | Diff | Splinter Review

Description Brian R. Bondy [:bbondy] 2012-02-04 07:35:45 PST
Created attachment 594445 [details] [diff] [review]
Patch v1.

In 2007, bug 375778 added the flag MOVEFILE_WRITE_THROUGH. This flag wasn't needed by the description of the problem in that bug though.

This flag causes the cache manager to flush the data to disk before returning.  

There is no benefit as far as consistency of the file data with subsequent calls though and we shouldn't do it from our file API because it incurs a cost of ~2ms.
Comment 1 Brian R. Bondy [:bbondy] 2012-02-07 05:59:31 PST
http://hg.mozilla.org/integration/mozilla-inbound/rev/8787499fae84
Comment 2 Marco Bonardo [::mak] 2012-02-07 15:05:27 PST
https://hg.mozilla.org/mozilla-central/rev/8787499fae84

Note You need to log in before you can comment on or make changes to this bug.