Last Comment Bug 724286 - Fix TelemetryTimestamps, AddonManagerPrivate global scope pollution and whitelist __SSi
: Fix TelemetryTimestamps, AddonManagerPrivate global scope pollution and white...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 13
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on:
Blocks: 715402
  Show dependency treegraph
 
Reported: 2012-02-04 10:33 PST by Dão Gottwald [:dao]
Modified: 2012-02-06 00:51 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.88 KB, patch)
2012-02-04 10:58 PST, Dão Gottwald [:dao]
dietrich: review+
Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2012-02-04 10:33:02 PST

    
Comment 1 Dão Gottwald [:dao] 2012-02-04 10:58:13 PST
Created attachment 594478 [details] [diff] [review]
patch
Comment 2 Dietrich Ayala (:dietrich) 2012-02-05 03:15:06 PST
Comment on attachment 594478 [details] [diff] [review]
patch

Review of attachment 594478 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/browser.js
@@ +139,5 @@
>  
>  __defineGetter__("AddonManager", function() {
> +  let tmp = {};
> +  Cu.import("resource://gre/modules/AddonManager.jsm", tmp);
> +  return this.AddonManager = tmp.AddonManager;

why can't you pass 'this' to Cu.import()?

r=me otherwise
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-05 06:34:04 PST
AddonManager.jsm exports another symbol (AddonManagerPrivate).
Comment 4 Tim Taubert [:ttaubert] 2012-02-05 09:15:55 PST
Which seems to be required by tests:

https://tbpl.mozilla.org/php/getParsedLog.php?id=9104264&tree=Try
Comment 6 Marco Bonardo [::mak] 2012-02-06 00:51:25 PST
https://hg.mozilla.org/mozilla-central/rev/75a63510cbcf

Note You need to log in before you can comment on or make changes to this bug.