Closed Bug 724297 Opened 10 years ago Closed 10 years ago

Firefox Sync launcher icon opens settings or Fennec main activity, not setup

Categories

(Firefox for Android Graveyard :: Android Sync, defect, P1)

ARM
Android
defect

Tracking

(firefox11 verified, firefox12 verified, firefox13 verified)

VERIFIED FIXED
mozilla13
Tracking Status
firefox11 --- verified
firefox12 --- verified
firefox13 --- verified

People

(Reporter: rnewman, Assigned: rnewman)

References

Details

Attachments

(1 file)

It seems to be taking the "I have an account" path, even when I don't have an account.

Chenxia, take a look?
I think the issue is that both the browser and the Sync setup wizard have the same task affinity. The default behavior in this case is to reopen the existing activity stack.

What's essentially happening is the same as would happen if Gallery and Camera on your phone had the same task affinity: you'd tap Gallery, and Camera would reopen.

I just tried out setting an explicit task affinity, and the problem disappears (though it is possible to get two setup UIs: one from the launcher, and one from Settings. That's not a showstopper, though.)

Quick diff attached. I will give a build to elancaster, see if it works for her.
Assignee: liuche → rnewman
Status: NEW → ASSIGNED
This build works (ICS, Galaxy Nexus. Clean: no other versions of FF or Sync installed)
- Launch Firefox Sync from icon: yields sync set-up
- Hit cancel and re-launch; yields sync set-up
- Launch Fennec; quit; re-launch sync: yields sync set-up
- Launch Fennec; quit; launch sync from about:home: yields sync set-up
Comment on attachment 594503 [details] [diff] [review]
Proposed patch. v1

[Approval Request Comment]
Regression caused by (bug #):
  Unknown. Possibly long-term.

User impact if declined:
  Firefox Sync setup interface won't launch as expected.

Testing completed (on m-c, etc.):
  Manual testing by myself and elancaster on assorted devices.
  Landed on m-i; will bake on m-c.

Risk to taking this patch (and alternatives if risky):
  Minimal. Alternatives would be to play with other Android manifest attributes to see if the same effect can be achieved… which is no less risky.

String changes made by this patch:
  None.
Attachment #594503 - Flags: review+
Attachment #594503 - Flags: approval-mozilla-beta?
Attachment #594503 - Flags: approval-mozilla-aurora?
tracking-fennec: --- → ?
https://hg.mozilla.org/mozilla-central/rev/b6494c69be6b
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
Comment on attachment 594503 [details] [diff] [review]
Proposed patch. v1

[Triage Comment]
Approved for Aurora 12 and Beta 11.
Attachment #594503 - Flags: approval-mozilla-beta?
Attachment #594503 - Flags: approval-mozilla-beta+
Attachment #594503 - Flags: approval-mozilla-aurora?
Attachment #594503 - Flags: approval-mozilla-aurora+
Duplicate of this bug: 724536
Nightly 13.0a1 (2012-02-08)
Aurora 12.0a2 (2012-02-08)
Beta 11.0 (2012-02-08)(20120208140504 - http://hg.mozilla.org/releases/mozilla-beta/rev/eab0f523de86)
Device: Samsung Google Nexus S - Android 2.3.6

Verified fixed: Firefox Sync launcher icon opens Settings to setup sync.
Status: RESOLVED → VERIFIED
Product: Mozilla Services → Android Background Services
tracking-fennec: ? → ---
Product: Android Background Services → Firefox for Android
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.