Closed Bug 724354 Opened 8 years ago Closed 8 years ago

Third party themes breaking media full-screen in W7 Aero

Categories

(Toolkit :: Video/Audio Controls, defect)

11 Branch
All
Windows 7
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: pjdkrunkt, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

Something in Aurora is making Themes break the media full-screen action.  If the window is non-maximized fullscreen is failing to properly initiate and showing a white background with the previous window shown in the middle.  F11 is the only way to back out.

I tested several themes marked as compatible with 11: 

Stratini Super - fails (does support full-screen button)
Nasa Night Launch - fails (no full-screen button support yet)
LavaFox V1 - fails (no full-screen button support yet)
Classic Compact - fails (does support full-screen button)

Walnut - works (does support full-screen button)
FT Deep Dark - works (does support full-screen button)
Firefox 3 theme for Firefox 4+ - works (no full-screen button support yet)
MX3 - works (does support full-screen button)
Could you please provide more details as to how to replicate this, including URL to use, exact steps (key strokes used, buttons clicked, etc) to take and browser configuration (e.g. toolbars enabled/disabled).  At first glance I could not replicate this issue using Classic Compact on WinXP using FF11 beta. I don't know if I'm doing something wrong.
Maybe Win7?  This happens for me 100% of the time using specific themes, configuration doesn't matter: tried after Safe Mode, tried a new profile with all extensions and plugins disabled, tried with hardware acceleration disabled, tried with all toolbars active, tried with all extra toolbars hidden, tried tabs on top and bottom, tried with video playing and with video paused.  

I've been testing on this site (it shows the Click to Play button):
http://tinyvid.tv/

Also happens consistently on the main Firefox video portal:
http://www.mozilla.org/en-US/firefox/video/

Steps for video with controls:

- Browser running the required theme in a non-maximized/non-fullscreen window.
- Load: http://tinyvid.tv/
- Press media Fullscreen button on player.

Steps for video with hidden controls:

- Browser running the required theme in a non-maximized/non-fullscreen window.
- Load: http://www.mozilla.org/en-US/firefox/video/
- Press play on the video to reveal controls.
- Press media Fullscreen button on player.
Just did some testing... this only happens in Windows 7 Aero. Tested in Windows 7 Basic and Classic and it does not happen.  Updated summary to match.
OS: All → Windows 7
Summary: Third party themes breaking media full-screen → Third party themes breaking media full-screen in Win Aero
Summary: Third party themes breaking media full-screen in Win Aero → Third party themes breaking media full-screen in W7 Aero
All that I can confirm right now is that I could not cause this behavior to happen in WinXP nor Win7 without Aero support. What is needed is a regression to figure out when it happened. Probably the best way to accomplish this would be to test of FF11 builds using divide and conquer. FF builds can be found at: https://ftp.mozilla.org/pub/mozilla.org/firefox/

The first FF11 build that I could find is at https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/11/2011-11-09-03-11-11-mozilla-central/

You'll need to download and install (or unzip and run) the correct build version and try to replicate the issue. The goal is to find the last build that does not produce the behavior and the first that does.
Just a followup for anyone who discovers this:  This behavior appears only in Aero Glass and seems to be caused by using any transparency color for #main-window in Fullscreen mode.  I guess the full-screen API doesn't like transitioning into transparency?  The fix is to force a solid color background for fullscreen.  Inserting the following into my theme fixed this:


@media all and (-moz-windows-compositor) {
  /* Make HTML5 video transition to Fullscreen mode seamlessly in Firefox 11+ */
  #main-window[inFullscreen="true"] {
    -moz-appearance: none;
     background-color: -moz-dialog!important;
  }
}

It's possible this could be considered a bug with the Fullscreen API that it breaks if transparency is used, but I'm going to mark this as INVALID for now.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.