Closed Bug 724480 Opened 8 years ago Closed 8 years ago

Update function on nightly non-functional since version bump to 2.10a1

Categories

(SeaMonkey :: Release Engineering, defect)

x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: u331436, Assigned: Callek)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120203 Firefox/13.0a1 SeaMonkey/2.10a1
Build ID: 20120203003008

Steps to reproduce:

In SeaMonkey nightly 2.9 and previous, using the Help --> Check for updates button triggered a new window which offered the possibility to download and update the current nightly to the the latest nightly.
Since the upgrade to 2.10a1, thins functionality does not work anymore


Actual results:

The "Check for Updates" message stays: No update found, SeaMonkey will check periodically for updates.


Expected results:

new daily nightlies updates should have been found and installed.
Confirmed.
> Confirmed.
therube: Didn't Callek arrange for editbugs for you? If so you can change the status yourself.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: General → Release Engineering
QA Contact: general → release
Ok, so this was a bug exactly where I suspected...

Our update server maps/mapped version numbers to specific branch names, and we had basically the following:

2.1* => comm-2.0

I changed that to have multiple maps, 

2.1a*
2.1b*
2.1p*   (for pre)
2.1.*

While that does miss the '2.1' I can fix that if we determine its a problem... I didn't think it worth testing that case for the defunct 2.1 branch....

I did test that this updated an older trunk nightly to the newest, so calling this fixed

Thank you again for reporting it
Assignee: nobody → bugspam.Callek
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.