Unregress handling of large standalone images that should span multiple pages when printing

VERIFIED FIXED in Firefox 11

Status

()

Core
Layout
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: dao, Assigned: dao)

Tracking

({qawanted, regression})

Trunk
mozilla13
qawanted, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox11 verified, firefox12 verified)

Details

(Whiteboard: [qa!])

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 594680 [details] [diff] [review]
patch

The comment explicitly refers to printing. Obviously doesn't make sense in a "not print" block.
Attachment #594680 - Flags: review?(roc)
Comment on attachment 594680 [details] [diff] [review]
patch

Review of attachment 594680 [details] [diff] [review]:
-----------------------------------------------------------------

er, nice catch!
Attachment #594680 - Flags: review?(roc) → review+
(Assignee)

Comment 2

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/4bb2bcc8c95a
Target Milestone: --- → mozilla13

Comment 3

6 years ago
https://hg.mozilla.org/mozilla-central/rev/4bb2bcc8c95a
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

6 years ago
Comment on attachment 594680 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): bug 713383
User impact if declined: low impact, regressing bug 528046
Testing completed (on m-c, etc.): manual on m-c
Risk to taking this patch (and alternatives if risky): no risk, alternative is to accept regressing bug 528046
Attachment #594680 - Flags: approval-mozilla-beta?
Attachment #594680 - Flags: approval-mozilla-aurora?

Comment 5

5 years ago
Comment on attachment 594680 [details] [diff] [review]
patch

[Triage Comment]
Approving for Aurora 12 and Beta 11 along with bug 713383 in support of printing images. Since this is landing fairly late, adding the qawanted keyword to get some extra testing around printing this cycle.
Attachment #594680 - Flags: approval-mozilla-beta?
Attachment #594680 - Flags: approval-mozilla-beta+
Attachment #594680 - Flags: approval-mozilla-aurora?
Attachment #594680 - Flags: approval-mozilla-aurora+

Updated

5 years ago
Keywords: qawanted
Whiteboard: [qa+]
(Assignee)

Comment 6

5 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/7a1b738dd4e7
http://hg.mozilla.org/releases/mozilla-beta/rev/3034f4ec14e9
status-firefox11: --- → fixed
status-firefox12: --- → fixed
Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20100101 Firefox/11.0

Tried with Firefox 11 beta 4 - printing the following image
https://bug528046.bugzilla.mozilla.org/attachment.cgi?id=411803
Prints on separate pages, as expected.(with/without zoom)
status-firefox11: fixed → verified
Whiteboard: [qa+] → [qa+] [qa!:11]
Should the image be printed on separate pages even without zoom?
https://bug528046.bugzilla.mozilla.org/attachment.cgi?id=411803
(Assignee)

Comment 9

5 years ago
(In reply to Paul Silaghi [QA] from comment #8)
> Should the image be printed on separate pages even without zoom?
> https://bug528046.bugzilla.mozilla.org/attachment.cgi?id=411803

yes
Verified fixed on Firefox 12b2:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Mozilla/5.0 (X11; Linux i686; rv:12.0) Gecko/20100101 Firefox/12.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20100101 Firefox/12.0
Status: RESOLVED → VERIFIED
status-firefox12: fixed → verified
Whiteboard: [qa+] [qa!:11] → [qa!]
You need to log in before you can comment on or make changes to this bug.