Last Comment Bug 724584 - ASSERTION: QueryInterface needed: 'query_result.get() == mRawPtr' in imgRequest::Init
: ASSERTION: QueryInterface needed: 'query_result.get() == mRawPtr' in imgReque...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: Joe Drew (not getting mail)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-06 10:01 PST by Marco Bonardo [::mak] (Away 6-20 Aug)
Modified: 2012-02-14 02:32 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
use nsIRequest (1001 bytes, patch)
2012-02-06 10:21 PST, Joe Drew (not getting mail)
jmuizelaar: review+
Details | Diff | Splinter Review

Description Marco Bonardo [::mak] (Away 6-20 Aug) 2012-02-06 10:01:59 PST
xul.dll!nsCOMPtr<nsIRequest>::Assert_NoQueryNeeded()  Line 532 + 0x2a bytes	C++
xul.dll!nsCOMPtr<nsIRequest>::operator=(nsIRequest * rhs)  Line 653	C++
xul.dll!imgRequest::Init(nsIURI * aURI, nsIURI * aCurrentURI, nsIRequest * aRequest, nsIChannel * aChannel, imgCacheEntry * aCacheEntry, void * aLoadId, nsIPrincipal * aLoadingPrincipal, int aCORSMode)  Line 162	C++
 	xul.dll!imgCacheValidator::OnStartRequest(nsIRequest * aRequest, nsISupports * ctxt)  Line 2211	C++

The JS Stack ends with PageThumbsProtocol.js::Channel_startRequest

Joe thinks it's due to the third argument here that should be aRequest and not the channel.
http://mxr.mozilla.org/mozilla-central/source/image/src/imgLoader.cpp#2207
Comment 1 Joe Drew (not getting mail) 2012-02-06 10:21:26 PST
Created attachment 594745 [details] [diff] [review]
use nsIRequest

I'm pretty sure that just using inheritance breaks XPCOM rules; luckily, we have this existing nsIRequest lying around.
Comment 2 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2012-02-13 14:37:10 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/1c7130f50c21
Comment 3 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-02-14 02:32:23 PST
https://hg.mozilla.org/mozilla-central/rev/1c7130f50c21

Note You need to log in before you can comment on or make changes to this bug.