Fix TARGET_CPU usage on ARM

RESOLVED FIXED in mozilla13

Status

()

Core
XPCOM
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Raúl Porcel, Assigned: Raúl Porcel)

Tracking

unspecified
mozilla13
ARM
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 594755 [details] [diff] [review]
arm.patch

xpcom/glue/objs.mk uses a generic 'arm' to check whether to build an ARM-specific object file or not.

The checks are done using "ifeq (arm,$(TARGET_CPU))", this would only work on Linux on those cases where the compiler has a CTARGET like arm-none-linux-gnueabi. Some other distros(gentoo, f.ex) use specific triplets for the different ARM subarchitectures, f.ex armv7a-unknown-linux-gnueabi, therefore making this check useless.

With the patch i'm attaching i'm doing the same approach as xpcom/reflect/xptcall/src/md/unix/Makefile.in, although in that case it uses OS_TEST and not TARGET_CPU, but the problem is the same as OS_TEST on ARM is ${target_cpu}.
(Assignee)

Updated

5 years ago
Attachment #594755 - Flags: review?(benjamin)
Attachment #594755 - Flags: review?(benjamin) → review+
(Assignee)

Updated

5 years ago
Assignee: nobody → armin76
Keywords: checkin-needed
http://hg.mozilla.org/integration/mozilla-inbound/rev/d05120728598
Keywords: checkin-needed
Target Milestone: --- → mozilla13
https://hg.mozilla.org/mozilla-central/rev/d05120728598
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.