Results in search do not appear in report/list

VERIFIED FIXED in 2.4.4

Status

Socorro Graveyard
Middleware
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: adrian, Assigned: adrian)

Tracking

Details

Comment 1

6 years ago
Thanks for filing. This has been originally raised by kbrosnan, so adding him.
I wonder if the issue is connected to bug 721169 somehow.
(Assignee)

Comment 2

6 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #1)
> I wonder if the issue is connected to bug 721169 somehow.

It shouldn't, bug 721169 is focused on a difference between TCBS and search. Since 2.4.1 search and report/list use the same code base, so a difference there is likely due to something else. 

I cannot reproduce in my VM yet, I'll have to wait for a fresh DB dump. Moving to 2.4.3.
Target Milestone: 2.4.2 → 2.4.3
(Assignee)

Updated

6 years ago
Target Milestone: 2.4.3 → 2.4.4
(Assignee)

Updated

6 years ago
Duplicate of this bug: 725313
(Assignee)

Comment 4

6 years ago
This problem is due to slashes ('/') in signatures. As Apache doesn't accept them and raise an error, we double-encode them in the UI before calling any URL. The problem is that at some point, I removed the decoding part in the middleware. I just need to add that again and it should come back to normal.

Comment 6

6 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/ff690a921b321f031878fed310e1044eabe3c5e7
Merge pull request #376 from AdrianGaudebert/724670-fix-slashes-in-signatures

Fixes bug 724670 - Decode double encoded slashes in terms and signature ...

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

6 years ago
Steps to QA
-----------

1. Go to advanced search.
2. Search for a signature containing a slash ('/'). Example: search for signatures containing "java.lang.RuntimeException: Unable to start activity ComponentInfo{org.mozilla.fennec/org.mozilla.fennec.App}"
3. Check that there are results.
4. Click on a signature to go to report/list.
5. Check that there are results.
(Assignee)

Comment 8

6 years ago
Note about step 2. in previous comment: this signature exists only for FennecAndroid, make sure to select that product. 

If no result is raised by that previous search, search for signatures containing "/" and continue.
Blocks: 730688

Updated

6 years ago
No longer blocks: 730688
Product: Socorro → Socorro Graveyard
You need to log in before you can comment on or make changes to this bug.