Last Comment Bug 724776 - Selecting a Character Encoding throws a ReferenceError: SetForcedCharset is not defined
: Selecting a Character Encoding throws a ReferenceError: SetForcedCharset is n...
Status: RESOLVED FIXED
[qa+]
: regression
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: 12 Branch
: All All
: -- normal (vote)
: mozilla13
Assigned To: Simon Montagu :smontagu
:
Mentors:
Depends on:
Blocks: 720310
  Show dependency treegraph
 
Reported: 2012-02-06 21:22 PST by blackrazor.qa
Modified: 2012-04-18 07:50 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
charset_error.docx (706.50 KB, application/octet-stream)
2012-02-06 21:22 PST, blackrazor.qa
no flags Details
Patch (1.18 KB, patch)
2012-02-06 23:04 PST, Simon Montagu :smontagu
gavin.sharp: review+
gavin.sharp: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description blackrazor.qa 2012-02-06 21:22:21 PST
Created attachment 594910 [details]
charset_error.docx

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120129021758

Steps to reproduce:

Click View -> Character Encoding -> More Encodings -> East Asian -> Chinese Simplified (GB2312).


Actual results:

A JS error was thrown: ReferenceError: SetForcedCharset is not defined.
Comment 1 blackrazor.qa 2012-02-06 21:24:55 PST
Bug was encountered in FF12/Aurora but filed using FF10. My apologies for any confusion.
Comment 2 Alice0775 White 2012-02-06 22:01:46 PST
Regression window(m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/388edf50e323
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120123 Firefox/12.0a1 ID:20120124003851
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/f173a9a1e056
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120124 Firefox/12.0a1 ID:20120124015351
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=388edf50e323&tochange=f173a9a1e056

Suspected: Bug 720310
Comment 3 Simon Montagu :smontagu 2012-02-06 22:17:41 PST
Ouch, I changed one call to SetForcedCharset to BrowserSetForcedCharacterSet and missed another one 5 lines below even though it's staring me in the face at https://bugzilla.mozilla.org/attachment.cgi?id=590816&action=diff#a/browser/base/content/browser.js_sec1
Comment 4 Simon Montagu :smontagu 2012-02-06 23:04:12 PST
Created attachment 594923 [details] [diff] [review]
Patch
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-07 09:25:21 PST
We really should have tests for all of this stuff.
Comment 7 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-02-07 14:58:37 PST
We need to fix this for 12.
Comment 8 Ed Morley [:emorley] 2012-02-08 09:39:45 PST
https://hg.mozilla.org/mozilla-central/rev/6b3f68d98dcd
Comment 9 Simon Montagu :smontagu 2012-02-13 21:58:27 PST
Comment on attachment 594923 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): 720310
User impact if declined: Unable to override page encoding in some scenarios
Testing completed (on m-c, etc.): On m-c since 2012-02-08
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None
Comment 10 Simon Montagu :smontagu 2012-02-14 01:32:54 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/49a2a17edbf6
Comment 11 Vlad [QA] 2012-04-13 03:18:49 PDT
I have verified this on:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0 beta 5
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20100101 Firefox/12.0 beta 5
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20100101 Firefox/12.0 beta 5

When following the steps from the description, no error are triggered.
On Ubuntu I've got some warnings but still no error. Is this intended?

Setting resolution to Verified.
Comment 12 Simon Montagu :smontagu 2012-04-14 23:10:18 PDT
(In reply to Vlad [QA] from comment #11)
> On Ubuntu I've got some warnings but still no error. Is this intended?

What warnings exactly?
Comment 13 Vlad [QA] 2012-04-18 00:16:12 PDT
There are no more warnings on a new profile.
Comment 14 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-04-18 07:50:13 PDT
(In reply to Vlad [QA] from comment #13)
> There are no more warnings on a new profile.

Thanks Vlad, can you verify on Firefox 13 as well so we can close this one out?

Note You need to log in before you can comment on or make changes to this bug.