Last Comment Bug 724855 - Add the missing nsIObserver interface to nsSmsManager
: Add the missing nsIObserver interface to nsSmsManager
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-07 05:44 PST by Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
Modified: 2012-02-09 10:37 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.12 KB, patch)
2012-02-07 05:48 PST, Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
bugs: review+
mounir: checkin+
Details | Diff | Splinter Review

Description Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2012-02-07 05:44:45 PST

    
Comment 1 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2012-02-07 05:48:35 PST
Created attachment 595003 [details] [diff] [review]
Patch
Comment 2 Mounir Lamouri (:mounir) 2012-02-07 06:09:36 PST
Comment on attachment 595003 [details] [diff] [review]
Patch

Review of attachment 595003 [details] [diff] [review]:
-----------------------------------------------------------------

This has nothing to do with Android.
Wonder why you asked the review to an Android peer....
Comment 3 Mounir Lamouri (:mounir) 2012-02-07 06:10:26 PST
For a bit of context: I wrote that patch but on Vivien's laptop, that's why he did attach it but the patch has my name.
Comment 4 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2012-02-07 06:13:54 PST
For more context, this patch fix an assertion that I hit when running Gaia's tests.
Comment 5 Olli Pettay [:smaug] 2012-02-07 07:48:44 PST
Comment on attachment 595003 [details] [diff] [review]
Patch

Why wasn't this noticed before?
Comment 6 Mounir Lamouri (:mounir) 2012-02-08 02:38:05 PST
Comment on attachment 595003 [details] [diff] [review]
Patch

I don't know why I haven't seen that during my tests. I guess the assert must have been lost in the logcat spam. Things seemed to work though.
Comment 7 Ed Morley [:emorley] 2012-02-09 10:37:35 PST
https://hg.mozilla.org/mozilla-central/rev/5c587c490cd7

Note You need to log in before you can comment on or make changes to this bug.