Last Comment Bug 724864 - perfprobe.cpp doesn't compile on mingw
: perfprobe.cpp doesn't compile on mingw
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla13
Assigned To: Jacek Caban
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-07 06:32 PST by Jacek Caban
Modified: 2012-02-09 10:37 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (4.54 KB, patch)
2012-02-07 06:32 PST, Jacek Caban
dteller: review+
Details | Diff | Splinter Review

Description Jacek Caban 2012-02-07 06:32:43 PST
Created attachment 595011 [details] [diff] [review]
fix v1.0

GCC doesn't accept friend statement without class keyword. Also mingw doesn't provide __in macro because it would conflict with std headers. Since they are no-op, removing them won't harm.

This I was at this, I've also fixed warnings about constructor initialization order and pointer to integer cast (TRACEHANDLE is an integer, while NULL is a pointer).
Comment 1 David Teller [:Yoric] (please use "needinfo") 2012-02-07 06:58:15 PST
Comment on attachment 595011 [details] [diff] [review]
fix v1.0

Review of attachment 595011 [details] [diff] [review]:
-----------------------------------------------------------------

Interesting. You have my r+ provided it passes TryServer.
Interestingly, I have not noticed any warnings when compiling with VS2010.
Comment 2 Jacek Caban 2012-02-08 02:59:03 PST
(In reply to David Rajchenbach Teller [:Yoric] from comment #1)
> Interesting. You have my r+ provided it passes TryServer.

Passed here: https://tbpl.mozilla.org/?tree=Try&rev=4c6837e03594

> Interestingly, I have not noticed any warnings when compiling with VS2010.

VS is generally less strict about that stuff (at least by default).

Thanks for the review, pushed to m-i:

https://hg.mozilla.org/integration/mozilla-inbound/rev/537e79b20314
Comment 3 David Teller [:Yoric] (please use "needinfo") 2012-02-08 12:39:38 PST
Thank you for the (very quick) fix.
Comment 4 Ed Morley [:emorley] 2012-02-09 10:37:18 PST
https://hg.mozilla.org/mozilla-central/rev/537e79b20314

\o/

Note You need to log in before you can comment on or make changes to this bug.