Closed Bug 725099 Opened 11 years ago Closed 11 years ago

RIL: Handle and report errors

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 713451

People

(Reporter: philikon, Assigned: ptseng)

References

Details

(Whiteboard: [good first bug][lang=js][mentor=philikon])

A potential type of response to a RIL request could be an error (e.g. if you're trying to send an SMS to a number that's invalid). We should process these errors and notify the main thread accordingly (preferrably including the info of the original request, e.g. the original message that kicked off the RIL request. This should be easier to do once we have fixed bug 725002.)
This shouldn't be too hard. Basically read the error code in RIL.processParcel, figure out which error it is (add ril.h's error constants to ril_consts.js) and then notify the main thread. Ideally comes after bug 725002 so that we can tell the main thread what call actually failed.
Whiteboard: [good first bug][lang=js][mentor=philikon]
Assignee: nobody → ptseng
This is a duplication of bug 713451.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 713451
You need to log in before you can comment on or make changes to this bug.