The default bug view has changed. See this FAQ.

Fix non-OS-double-buffered GL layers

RESOLVED FIXED in mozilla15

Status

()

Core
Graphics
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Joe Drew (not getting mail), Assigned: Joe Drew (not getting mail))

Tracking

Trunk
mozilla15
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 595192 [details] [diff] [review]
Invert texture coordinates

The single-buffering path is broken right now, but this fixes it.
Attachment #595192 - Flags: review?(bjacob)
You rock! Does non-OS-double-buffering work on B2G with that patch?
Summary: Fix single buffering in GL layers → Fix non-OS-double-buffered GL layers
(Assignee)

Comment 2

5 years ago
Not really, unfortunately. We still get some bad rendering. More investigation is necessary.

Comment 3

5 years ago
Oh wow this could be great. Can you test switching off double buffering by flipping that bool and applying this patch? We desperately need that to stop tearing.
We need this patch as insurance against what appear to be driver bugs, so it's quite high priority for b2g.  What's the status here?  Not ready for review yet?
(Assignee)

Comment 5

5 years ago
Note that even if you apply this patch, you still need to turn off double buffering at GLContextProviderEGL.cpp:2016 before it'll take effect.
(Assignee)

Comment 6

5 years ago
Finally got a test build up on the Maguro device while using single buffering. Still shows problems (flashing the lock screen this time), which implies that the problem is a fundamental one involving FBOs on the Maguro's drivers.
Comment on attachment 595192 [details] [diff] [review]
Invert texture coordinates

Review of attachment 595192 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry, I apparently forgot to r+ this.
Attachment #595192 - Flags: review?(bjacob) → review+
(Assignee)

Comment 8

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/571e46266e96
https://hg.mozilla.org/mozilla-central/rev/571e46266e96
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla15
You need to log in before you can comment on or make changes to this bug.