Package jsinspector.xpt in SeaMonkey

VERIFIED FIXED in seamonkey2.10

Status

SeaMonkey
Build Config
P2
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

Trunk
seamonkey2.10
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

6 years ago
Created attachment 595228 [details] [diff] [review]
(Av1) Package jsinspector.xpt
[Checked in: Comment 3]
Attachment #595228 - Flags: review?(bugspam.Callek)
Comment on attachment 595228 [details] [diff] [review]
(Av1) Package jsinspector.xpt
[Checked in: Comment 3]

I am curious if this work breaks/hurts DOMi or Venkman, just to be clear
Attachment #595228 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 3

6 years ago
Comment on attachment 595228 [details] [diff] [review]
(Av1) Package jsinspector.xpt
[Checked in: Comment 3]

http://hg.mozilla.org/comm-central/rev/8dfd634cfb27
Attachment #595228 - Attachment description: (Av1) Package jsinspector.xpt → (Av1) Package jsinspector.xpt [Checked in: Comment 3]
(Assignee)

Comment 4

6 years ago
(In reply to Justin Wood (:Callek) from comment #2)
> I am curious if this work breaks/hurts DOMi or Venkman, just to be clear

Hopefully not.
Though I wonder what "relations" are between all these tools (DOMi, Venkman, Firebug (and ChromeBug), Web Console, ..., and now these (upcoming) ones)...
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(In reply to Serge Gautherie (:sgautherie) from comment #4)
> (In reply to Justin Wood (:Callek) from comment #2)
> > I am curious if this work breaks/hurts DOMi or Venkman, just to be clear
> 
> Hopefully not.
> Though I wonder what "relations" are between all these tools (DOMi, Venkman,
> Firebug (and ChromeBug), Web Console, ..., and now these (upcoming) ones)...

The new debugger code shouldn't hurt anything else, since it's high-level code. The nsIJSInspector interface is the only low-level code in it and it's only used in one place. The jsdbg2/jsd2 code that the js team landed a few months ago and is still being worked on, is designed to work in parallel with jsd, so Venkman and Firebug should be safe. My team (devtools) is actively looking for regressions in Firebug and some of us use DOMi and Chromebug as well.

Long-term, our plan is to offer superior functionality to DOMi and Venkman, effectively replacing them.
(Assignee)

Comment 6

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1328656239.1328662371.30260.gz&fulltext=1
WINNT 5.2 comm-central-trunk build on 2012/02/07 15:10:39
{
+bin/components/jsinspector.xpt
}

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1328672372.1328676929.27055.gz&fulltext=1
WINNT 5.2 comm-central-trunk build on 2012/02/07 19:39:32
{
bin/components/jsinspector.xpt
}

V.Fixed

*****

(In reply to Panos Astithas [:past] from comment #5)
> Long-term, our plan is to offer superior functionality to DOMi and Venkman,
> effectively replacing them.

Thanks for the explanation. Looking forward to (more) up-to-date (more) maintained tools :-)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.