Last Comment Bug 725138 - tidy up formal access, remove dead Stack code
: tidy up formal access, remove dead Stack code
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla13
Assigned To: Luke Wagner [:luke]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-07 15:56 PST by Luke Wagner [:luke]
Modified: 2012-02-09 10:29 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
tidy up Stack (16.23 KB, patch)
2012-02-07 15:59 PST, Luke Wagner [:luke]
bhackett1024: review+
Details | Diff | Splinter Review
simplify Interpret args/local ops (4.81 KB, patch)
2012-02-07 16:01 PST, Luke Wagner [:luke]
bhackett1024: review+
Details | Diff | Splinter Review

Description Luke Wagner [:luke] 2012-02-07 15:56:52 PST
Just flushing out some built-up cleanup patches from farther-out patches.
Comment 1 Luke Wagner [:luke] 2012-02-07 15:59:28 PST
Created attachment 595235 [details] [diff] [review]
tidy up Stack

This patch
 - undoes more of the changes from the old Stack/StackSpace split,
 - removes resetCallFrame; it is dead (didn't I already do this?)
 - kills these initJitFrame* functions since they don't actually describe what the prologue is doing anymore, merging two of them into initFixupFrame, since that is actually used (by getFixupFrame in FixupArity).
Comment 2 Luke Wagner [:luke] 2012-02-07 16:01:11 PST
Created attachment 595236 [details] [diff] [review]
simplify Interpret args/local ops

Tiny patch, just uses formalArg (useful later when arg access is more dynamic) and adds localSlot for symmetry.

Note You need to log in before you can comment on or make changes to this bug.